PyCharm not opening on Windows 10

已回答

This has been happening on and off for me for a couple of weeks now. Whenever I try to launch PyCharm from the stat menu, it almost feels like there's a 50/50 chance of the window actually popping up. Can't put my finger on it as to why it happens. I also don't necessarily see a new process show up in my Task Manager. Trying the .exe's in the bin folder has the same behavior. 

Using Windows 10, Java is up to date

Has anyone encountered something similar? 

0

I faced the same issue with my PyCharm 2020.1.2 but MSchmitt's solution worked perfectly. Someone give him a LifeSaver Medal. If you're reading this, Thank you MSchmitt 

0

I had the same problem, not even the opening pop-up showed up. Later, I found out a Visual C++ 2017 Redistributables was missing when I was looking for a screen recorder. So I installed it, and PyCharm worked. If it helps, the link I accessed:

https://obsproject.com/visual-studio-2017-runtimes-64-bit

0

I have the same issue -->  Upload id: 2020_08_17_NbqT6yf138jnT7mK (file: idea.log)

0

No matter what you try for opening pycharm...

the only way to solve this is go to terminal(command prompt/ powershell) > type pycharm > and pycharm will open up.

no other way i found to open pycharm with launcher icon or shortcut, just terminal.

0

Hello @Adnankhanmgdp

 

Please make sure the latest Visual C++ Redistributable package from https://support.microsoft.com/en-gb/help/2977003/the-latest-supported-visual-c-downloads (at the moment, the latest is the one for Visual Studio 2015, 2017 and 2019) is installed. 

 

If this is not the case, please submit a ticket https://youtrack.jetbrains.com/issues with logs folder zipped from ***Help | Collect logs and Diagnostic Data*** attached. 

 

Thank you! 

0

Wiping out the custom .vmoptions file did it for me. <whew!>

0

YAY! I FOUND A SOLUTION! IT WILL [MOST LIKELY] WORK FOR ALL OF YOU!!!

 

I went digging and found a YouTube video with ~500 views, but it had a really great solution.

 

First, locate to this URL on your browser. It will take you to a website to download "vcruntime".

Next, download the latest version of vcruntime. If at any point this doesn't work, come back to this step and download another version. 

Then, you will see a .zip folder downloading. Once that's done, open that ZIP folder and copy the DLL file in that folder.

Afterwards, locate the binary folder of your PyCharm app. It should be at "C:\Program Files\JetBrains\PyCharm {EDITION & VERSION}\bin.

Finally, copy the DLL file into the binary folder. Restart and try opening PyCharm.

 

This worked for me and hopefully it does for you!

0

i am unable to open pycharm after update installation in my windows as well as in mac book m1

please help me

 

0

Faced this issue and all but one solution mentioned above didn't work. Run the pycharm.bat file from the bin folder. Thanks to whoever suggested. Three months of struggle has ended!

0

I found out a solution for this. Turn out, PyCharm on Windows requires administrator right for this open dialog to show up. You can right click on the app > PyCharm > right click > Run as administrator. After that, you can open file or project normally.

1

Hi, I faced this issue today when I restarted a Jupyter server. It was out of the blue. I tried all solutions, but all failed. I had recently installer JDK 16, when I uninstalled that (leaving JDK 8), the issue subsided.

0

For me the Pycharm window tried to appear on a monitor I had disconnected from. Rebooting the computer did not work, but this worked:
"shift + right click" the launcher in the task bar -> move -> use arrow buttons to move the window onto your main screen!

1

I think I found the solution that will solve this problem once and for all.

What I did is I went to:

C:\Users\{username}\AppData\Roaming\JetBrains

and deleted everything in there.

Important Notes:

1. This action will likely delete all previous custom PyCharm settings, plugins, configurations, licenses etc. 

2. I didn't have any other JetBrains products installed except for an older version of PyCharm  (which I uninstalled but apparently its folder remained even after uninstalling the older version). So you might want to delete the PyCharm  folder first and see if that solves the problem.

3. The AppData folder is a hidden system folder so you need to set Windows to display hidden and system files 

0

I had the same issue. Application was running in  background . I had to end the process from Task Manager and reopen it to make it work.  

0
  • open cmd as admin
  • tasklist /fi "username eq your_user_name" /fi "Imagename eq app_name.exe"
  • taskkill /fi "username eq your_user_name" /fi "Imagename eq app_name.exe"
0

请先登录再写评论。