DataGrip does not show tables under schema

Hi,

I have configured my database in DataGrip and everything works fine except that I cannot see the tables under schema. I have similar configuration for other database, which has no problem at all. Is there any setting I missed?

As you can see in the screenshot, tables show up in the database "Snapmobile". However, nothing show up in "Pixels Redshift". Both databases are AWS Redshift.

Thanks!

 

12

Hi Maxim,

I need to follow a strict configuration order to make the tables appear:

1. Enter credentials and click "Test Connection" button (this is a must). And DO NOT click the "OK" button to exit the config window.

2. Click the options tab, click all the check boxes of the schemas under "Resolve unqualified references". At this moment the "introspect metadata using JDBC" option is not there yet. Click "OK" to close the config window.

3. Wait the downloading of the table information. Expand the data source then you can see the tables.

If I do not follow this order I won't get table list.

My issue is solved for now. Thanks!

5

right click - > Database Tools -> Forget Cached Schema -> Synchorize 

which solved mine with version 2017.01

5

"I see said the blind man." When one clicks Schemas to select which databases to display, one needs to click the arrow next to the database name and choose which or all schemas to display for that db. Once chosen, they are displayed in the database window.

That could be a little more intuitive, maybe having "all schemas" be a default?

Consider my particular issues as solved. Unfortunately, I did remove all traces of datagrip and re-installed it to make this little discovery.

4

My problem is solved!Method is

1.

2.

3

I had this problem, latest version of DG with a connection to redshift.  The main issue is the introspection fails and the tables are never shown.  I can query them and use them but not see them.  To fix this, go to connection properties -> "Auto Sync All Schemas"  and uncheck "use pre-inspected objects for system catelogs that are not introspected" and check "introspect using jdbc metadata".  Then apply, okay, and refresh the data connection. 

2

Please, note that for PostgreSQL-based DBs is "one connection — one database", so make just another datasource for Pixels.

1

Maxim,

You are right. I have 2 instances connecting to 2 different Redshift. Both 2 users have the admin permission. Although Pixels is not introspected, I can run this query

select * from pg_catalog.pg_tables where schemaname='public'
order by tablename;

to get all the table information and I can do all the read/write queries on those tables. So I think it is not permission issue.

I just did another test, create a another connection to Snapmobile Redshift, it is not introspected.

1

Hi Maxim,

I have tested a few old version of DataGrip:

DataGrip      1.0.3 Build#DB-143.2263, build on Feb 18, 2016
DataGrip 2016.1.1 Build #DB-145.863, build on May 6, 2016
DataGrip 2016.1.2 Build #DB-145.864, build on July 4, 2016

Surprisingly they all work!

I found that since version 2016.2 there is a UI/UX change, you have to manually add those schemas to view.

In previous version, by default, those schemas are all visible, and information downloading starts automatically once the data source is set.

I can see the downloading progress bar in the older versions and once everything is downloaded I can see all the tables under the public schema. I have a feeling that it could be this change caused the table information not downloaded.

I hope this can help you resolve the issue.

Thanks.

 

1

Thanks! So, first you needed to press SYNC button, and then More Schemas... appeared, right?

Am I getting it right, that now Pixels is introspected, after you used More Schemas...?

1

I'm having the same issue but with SQL server.  I have a database with several schemas, I can query everything (the intellisense aspect works fine), but cannot actually see any tables/views/routines in the database window.  When double clicking on tables in the stock schema I see:

[08004][911] Database 'stock' does not exist. Make sure that the name is entered correctly.

Stock isn't a database it's a schema.

I've got another SQL server that works fine.  Resolve unqualified references has all the schemas ticked.

EDIT: Running latest EAP : 

DataGrip 2016.3 EAP
Build #DB-163.5644.18, built on October 7, 2016
DataGrip EAP User
Expiration date: November 6, 2016
JRE: 1.8.0_112-release-b408 x86
JVM: OpenJDK Server VM by JetBrains s.r.o

EDIT2: Fixed - I removed the connection and re-added and now I can see tables for all the schemas

1

@vasily, I've been trying this for a year now. None of your solutions work, including introspecting the schema. On another note, if that's required, why isn't it on by default.

Because of these limitations, we avoid using Jetbrains for any kind of database interaction, which is frustrating.

1

@Tyler Hartwig & @Peter Varsanyi our quick steps guide should help you https://www.jetbrains.com/datagrip/quick-start/

1

Hi Maxim, I removed out the connection and reconnected and now it's working fine. I don't think there is a problem with the schema, I can connect to it using PgAdmin just fine, execute queries etc. I will take a screenshot if/when it happens again. Thanks

1

Yes, I meant that, Please write this in the issue. 

1

I have the same problem,I follow the instructions and clean up the cache, but it gets stuck in one place。version 2019.1.1,but I can query with SQL

1

same issue happening with me.

 

I've two different docker containers both has same database one has a previous version and the 2nd has a new one. On new database I created a couple of new tables now whenever I switch container instead of sync I have to delete the old connection and create a new one.

 

1

vasily chernov

I upgraded to version 2021, and the problem seems to have been resolved.

1

I have the same problem, it will be very helpful to solve it

0

I have the same problem. Cannot see any tables.

0

Hi Maxim,

Thanks for your reply.

In my case, the Pixels and Snapmobile are two different datasources. However, I still cannot see the content under the public schema. Any idea why?

0

Yeah I see, thanks!

Can you please tell what version do you use?

And if it works on 2016.1 (You can download it here: https://confluence.jetbrains.com/display/DBE/DataGrip+previous+releases

Thanks!

0

Hi Maxim,

The version I am using now is 2016.2.1 BUILD #DB-162.1628.37, build on August 15, 2016. I haven't got time testing the earlier version yet. I will let you know once I did.

Thanks!

 

0

So, the fact is: you have 2 instances and one is introspected, and the other is not. May be you have different type of rights on Pixels?

0

I have the same problem.

0

Hi, guys! Finally, we discovered the reason of this and thank you for your reporting. Lawrence, your workaround is right, and it helped us to explore a cunning thing inside the code-base.

Fix will be in 2016.2.3 which is supposed to be released during these days.

Thanks again!

0

I am having a similar issue, against a Kerberized Hortonworks Hive.

I was getting "autocommit" errors in 2016.2.6.... I am trying the 3 EAP now....

No more "autocommit" errors, but nothing shows up under my database.

Ive checked all boxes under options/Resolve unqualified references... All tables show up there

Just not in the UI.

 

Any ideas?

 

0

Thanks Max!

A revised jar definitely worked out better.

0

I seem to be having issues with Netezza. Has this bug been fixed?

0

请先登录再写评论。