How to disable documentation pop-up/pane in PyCharm?

已回答

Everytime I open PyCharm, an empty documentation pop-up or pane open, which is very annoying, and I have to close it.

How do I disable it completely?

 

PyCharm 2018.1.4 (Professional Edition)
Build #PY-181.5087.37, built on May 24, 2018
JRE: 1.8.0_152-release-1136-b39 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 4.16.13-1

6

Hi Homocomputeris! Do you have Scientific Mode enabled (View | Scientific Mode)?

0

Hi, Pavel!

Yes, I do. Is it possible to suppress the docs pop-up in the Scientific mode?

0

Unfortunately, it is not possible without disabling the Scientific mode. I created a ticket in our bug tracker to cover this problem: PY-30332.

0

Thanks.

The problem is I have disabled Scientific Mode but the pop-up still appears (sometimes). The worst thing it appears on top of all other windows.

0

I agree this is terribly annoying.  

How can I disable the auto documentation pop-up window in scientific mode?

0

Fudge, Daniel PWC

If you're talking about the OP issue, it was fixed as per PY-37579

I you have another issue, please provide screenshots and steps to reproduce.

0

I guess you meant this one: https://stackoverflow.com/questions/39522113/how-to-stop-annoying-documentation-popups-in-intellij-idea

It's in intellij, but the setting is the same with pycharm. File - Setting - Code Editing then uncheck "Show quick documentation on mouse move"

1

This is still not solved. 
I have it with scientific mode and even when I de-activate it, the documentation keeps popping up annoyingly...

1

Francisco Jose Torres Herrador

What PyCharm version do you use?
Could you share a screenshot showing what the documentation window looks like in your case?

0

Hi, thanks for the quick reply. 

I am using 2021.3. 

See the screenshots attached.

The documentation that bothers me is the one on the right.

The one on top of the function is actually very useful. 

 

Best, 

Francisco

1

Do you have File | Settings | Editor | Code Editing | Show quick documentation on hover enabled?

If so, disabling it should do the trick.

0

Yeah, it is disabled and it still does the same thing...

 

1

I wonder if there is something wrong with your config.

Try File | Manage IDE Settings | Restore Default Settings...
Has it helped?

If it did, then you can try importing the config back with File | Manage IDE Settings | Import Settings... from the backup that PyCharm created on the first step.

1

Restoring to default settings worked!

However, if I re-import the saved backup, the problem re-appears...

I guess there must be some old data stored in the settings which is indeed messing up.

1

Update: I restored the settings from the sync option. Seems to work well! thanks!

1

Hey Team,

how to disable this shit?

0

Hi Andrey,

thanks a lot, I did it and will monitor the behaviour.

if possible let's consider it is my feature request - disable\shutdown this feature by default (new installation PyCharm).

0

Try checking this on the documentation panel, it worked for me

0

请先登录再写评论。