VCS > Commit... does nothing


This started earlier today, possibly with the 2018.1.4 update, though I'm not sure. I'm using Git via CLion, and I've changed some tracked files. When I choose VCS > Commit..., it does nothing. When I press the shortcut key for that menu item, the menu flashes, but otherwise it does nothing. I can commit from the command line. Restarting CLion doesn't help; changing Git repos doesn't help. Is anyone else having a problem like this?


The same bug!

Got it after update to 2018.1.4.

Fetch, pull and push works fine.


Same here with 2018.1.4


Updating to 2018.1.5 fixed it for me.


Hi! You are right, it seems to be fixed in CLion 2018.1.5. We are sincerely sorry for the inconvenience.


The problem just happened again for me in CLion 2020.2.3. Pressing the "commit" or "commit and push" button had almost no effect when I tried to commit GIT changes on CLion on Mac. Sometimes a window "Performing VCS Refresh" showed up for a millisecond. GIT from command line worked as usual.

"File -> Invalidate Caches / Restart" solves the problem temporarily for me. But I have to invalidate the cache multiple times a day (and for multiple projects). This is annoying.


This is still an issue for me with the latest versions of PHPStorm and GoLand (2020.2.3). Cache invalidation/restart doesn't help. Any idea how to debug this issue further? Thanks


I have the same problem now with IntelliJ IDEA Ultimate 2020.2.2, build from September 15th. I can click the commit button as much as I want, it doesn't do anything.

EDIT 1: cache invalidation and/or restart won't help either!

EDIT 2: I only have this problem with a select group of projects... in some, commit doesn't work anymore, in others it does.

EDIT 3: I deleted one of the projects where commit is broken and cloned it again; commit is still (or again) not working in that project.

NOTE: After I changed the commit settings (little cogwheel icon in the commit dialog) and disabled all checkboxes (TODO checks, perform SonarLint analysis, Go fmt) it works.

I had a SonarLint update today, so I heavily suspect the SonarLint plugin to be the culprit now!


In my case, the SonarLint plugin is definitely causing the "Commit" button issue. I verified that the "Commit" button doesn't work anymore as soon as I enable SonarLint checks on commits.

Amazingly enough, it only happens in some projects, not in others. One project where I have this issue is a non-Java project, and also doesn't have a Maven POM. Other Java / Maven projects don't seem to have the problem.



There is a bug reported, please see and vote:

Please feel free to comment. 


I am having the same problem after the latest update in GoLand


Recently i hit this problem very frequently on:

IntelliJ IDEA 2021.2.3 (Ultimate Edition)
Build #IU-212.5457.46, built on October 12, 2021
Licensed to Antonio Bloise
Subscription is active until April 3, 2022.
Runtime version: 11.0.12+7-b1504.40 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
Windows 10 10.0
GC: G1 Young Generation, G1 Old Generation
Memory: 4096M
Cores: 12
Registry: ide.intellij.laf.enable.animation=true, ide.balloon.shadow.size=0
Non-Bundled Plugins: manjaro.mpb (1.6), org.sonarlint.idea (, zielu.gittoolbox (212.7.15), EclipseCodeFormatter (, com.intellij.aspectj (212.4746.52), MavenRunHelper (, com.intellij.tapestry (212.4746.52), com.github.iguissouma.nxconsole (0.34.0), intellij.prettierJS (212.5080.8), org.jetbrains.kotlin (212-1.5.31-release-546-IJ4638.7), izhangzhihao.rainbow.brackets (6.21)
Kotlin: 212-1.5.31-release-546-IJ4638.7


Got the same problem on PhpStorm 2021.3. Invalidate doesn't help..


I have the same problem with Idea Ultimate 2021.3.2. Invalidate does not help. I have unticked flag "Analyze code" in the "Show commit options" cogwheel and this helped.