Please update Gradle plugin for latest

Gradle plugin has version 4.0 and it is not compatible with Java version "9.0.4", so when I create New Gradle project using 'Use default gradle wrapper(recommended)" it is using(or downloading) Gradle version 4.0 automatically and then after it sync the project. I have installed latest Java(9.0.4) so at synch time it throws an error that :

Could not determine java version from ‘9.0.4’

I had to install manually Gradle 4.5 files to Gradle>libs folder 

IntelliJ IDEA I am using:

  • Version: 2017.3.4
  • Build: 173.4548.28
  • Released: January 30, 2018
6

I can confirm that this bug exists.

 

The way I fixed it on OSX was to go to:

Intellij IDEA --> Preferences --> Build, Execution, Deployment --> Gradle 

Change to 'Use local gradle distribution'

Change 'Gradle home' to '/usr/local/opt/grade/libexec'

2

I tried the solution from Trent, but it does not work.

 

Should i install manually gradle before? 

0

Gradle itself works fine. Plugin is a problem maker.

 

UPD. Solved by upgrading to idea-IC-181.4445.78

0

Trent's workaround works for me, please fix this bug, one of the points to use gradle is use the wrapper and DON'T NEED INSTALL GRADLE LOCALLY

 

regards

Edson

0

For those who land on this page because they are looking for how to update Gradle in IntelliJ.
This page explains that relatively well:
https://docs.gradle.org/current/userguide/gradle_wrapper.html#sec:upgrading_wrapper

With me (Windows) it was:
gradlew.bat wrapper --gradle-version 6.6.1

0

请先登录再写评论。