RUN simply stopped working for one single project which previously worked fine (no changes to configuration)

已回答

Info:

- Using community edition 2018.1.5 (reinstall didnt help)

- Using Java 1.8.0_121 (exactly the same as from before the issue)

- Reimporting projects didn't help

- Fetching it again in different path - didnt help

- Removing idea folder and iml files didnt help

- Invalidating caches didnt help

- Run button is present while clicking on main function and on main class.

- Run is grayed out next to "THE SAME" run configuration at the top-right (its the same configuration ive used previously - nothing changed)

- There are ZERO logs about what went wrong...

- "Running" application simply does "nothing" - Before Launch "Build" option is completely neglated, who when i rebuild project it works fine

 

Im really buffled, spent like 3 hours now banging my head against it, because it makes no sense.

评论操作 固定链接

I'm experiencing this same issue on IDEA 2018.1.5 Ultimate.

It's very basic project with jdk8, javalin (kotlin) and lombok dependencies, with main class on it. IDEA is behaving exactly as others wrote, it does nothing on run button click and then run button disappears. Same goes for debug button etc.

https://github.com/mgorgon/jbr

I'll try tomorrow with IDEA 2019.

btw as others pointed out, disabling Gradle 181.5281.24 plugin makes everything work fine (even if it's maven project).

0
评论操作 固定链接

@Marcin Gorgoń could you please upload the project, including project configuration files (.idea sub-directory and module's .iml files) and your File | Export settings... jar. For uploading you can use ftp://ftp.intellij.net/.uploads / https://uploads.services.jetbrains.com or any file sharing service. Thank you.

0
评论操作 固定链接

Sure, uploaded files.zip to uploads.services.jetrbrains.com. However, I didn't received any ref except file name.

0
评论操作 固定链接

Thank you. Unfortunately, still could not reproduce it. Please try 2019.1 version.

0
评论操作 固定链接

I also have the same problem suddenly, the logs output this error:

Version used: 2019.1

2019-04-29 10:51:23,613 [ 521150] INFO - ij.compiler.impl.CompileDriver - null keys not supported
java.lang.NullPointerException: null keys not supported
at gnu.trove.THashMap.put(THashMap.java:161)
at com.intellij.util.graph.GraphGenerator.buildOuts(GraphGenerator.java:62)
at com.intellij.util.graph.GraphGenerator.<init>(GraphGenerator.java:41)
at com.intellij.util.graph.GraphGenerator.generate(GraphGenerator.java:32)
at com.intellij.util.graph.impl.GraphAlgorithmsImpl.computeSCCGraph(GraphAlgorithmsImpl.java:85)
at com.intellij.util.graph.impl.GraphAlgorithmsImpl.computeStronglyConnectedComponents(GraphAlgorithmsImpl.java:132)
at com.intellij.compiler.ModuleCompilerUtil.computeSourceSetCycles(ModuleCompilerUtil.java:151)
at com.intellij.compiler.ModuleCompilerUtil.getCyclicDependencies(ModuleCompilerUtil.java:100)
at com.intellij.compiler.impl.CompileDriver.b(CompileDriver.java:659)
at com.intellij.compiler.impl.CompileDriver.make(CompileDriver.java:93)
at com.intellij.compiler.impl.CompileDriver.make(CompileDriver.java:89)
at com.intellij.compiler.CompilerManagerImpl.make(CompilerManagerImpl.java:253)
at com.intellij.task.impl.JpsProjectTaskRunner.c(JpsProjectTaskRunner.java:120)
at com.intellij.task.impl.JpsProjectTaskRunner.run(JpsProjectTaskRunner.java:79)
at com.intellij.task.impl.ProjectTaskManagerImpl.run(ProjectTaskManagerImpl.java:171)
at com.intellij.compiler.options.CompileStepBeforeRun.a(CompileStepBeforeRun.java:160)
at com.intellij.openapi.application.TransactionGuardImpl.runSyncTransaction(TransactionGuardImpl.java:88)
at com.intellij.openapi.application.TransactionGuardImpl.lambda$submitTransaction$1(TransactionGuardImpl.java:111)
at com.intellij.openapi.application.impl.LaterInvocator$FlushQueue.doRun(LaterInvocator.java:435)
at com.intellij.openapi.application.impl.LaterInvocator$FlushQueue.runNextEvent(LaterInvocator.java:419)
at com.intellij.openapi.application.impl.LaterInvocator$FlushQueue.run(LaterInvocator.java:403)
at java.desktop/java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.desktop/java.awt.EventQueue.dispatchEventImpl(Unknown Source)
at java.desktop/java.awt.EventQueue$4.run(Unknown Source)
at java.desktop/java.awt.EventQueue$4.run(Unknown Source)
at java.base/java.security.AccessController.doPrivileged(Native Method)
at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
at java.desktop/java.awt.EventQueue.dispatchEvent(Unknown Source)
at com.intellij.ide.IdeEventQueue.defaultDispatchEvent(IdeEventQueue.java:741)
at com.intellij.ide.IdeEventQueue._dispatchEvent(IdeEventQueue.java:690)
at com.intellij.ide.IdeEventQueue.dispatchEvent(IdeEventQueue.java:385)
at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.desktop/java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.desktop/java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.desktop/java.awt.EventDispatchThread.run(Unknown Source)

0
评论操作 固定链接

The exception is not related to discussed here problem. Please try deleting IDE Caches directory and restart.

0
评论操作 固定链接

Had the same issue, run/debug command was not doing anything and was getting disabled after the first click. Disabling the Gradle plugin resolved the problem.

0
评论操作 固定链接

I have similar problem.

IntelliJ IDEA 2019.1.3 (Ultimate Edition)
Build #IU-191.7479.19, built on May 28, 2019
JRE: 1.8.0_202-release-1483-b58 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 5.1.5-arch1-2-ARCH



I've created a new maven project via Spring Initializer (plain project, no enabled features). Running the project first time seems to work, then running it a bit later hangs on the Build.
If I restart the IDE, then the first time works fine, but after awhile, trying to run it again fails. Same running tests or debugging.

If I disabled Gradle plugin, I still get the problem.

0
评论操作 固定链接

Please file a bug at https://youtrack.jetbrains.com/issues/IDEA with idea.log and build.log attached: https://intellij-support.jetbrains.com/hc/articles/207241085 .

Also provide the thread dumps of IntelliJ IDEA and build processes (jps) using jstack: https://intellij-support.jetbrains.com/hc/articles/206544899 .

0
评论操作 固定链接

Thanks for the solution and yes disabling the gradle plugin worked for me even though I have a maven project

0
评论操作 固定链接

I have a maven project and had run into the same issue after upgrading some of my Serenity dependencies.

I can confirm that disabling Gradle plugin has helped me out.

1
评论操作 固定链接

Locate the temp working directory for IDE, for instance win7 have it under C:\Users\<<user>>\.IdeaIC2017.3

Delete this directory, and reimport your project.

Worked for me!

0
评论操作 固定链接

'File > Invalidate Caches / Restart' worked for me

0
评论操作 固定链接

I see people talking about disabling gradle plugin in their maven project.

I am having same issue in a multi-module project, but I can't find any gradle plugin in my maven project.

Can someone help me find this gradle plugin?

0
评论操作 固定链接

Hey, It is found in the intellij plugins (not maven plugins)

Use shift twice and search for the intellij plugin menu

1

请先登录再写评论。