Git commit, no changes detected (problem solved)

已回答

Hi all :

After I edit a file and commit, it always shows " No changes detected ", and the file I edit, the color change to not what I usually seen before.

Normally should change into this color, right?

 

Meanwhile,  local changes always show " default " after I edit any files in the project.

 

I am not sure it's IDE's problem or git's problem, so I use Sourcetree application, and it worked with commit and push to my GitHub successfully.

Here's my IDE Settings / Version Control view

And my Help / Show Log in Explore  file link

http://goo.gl/UEqstz

 

My develop environment OS Windows10, Webstorm version is 2018.1.

0

Seems the status of the files shown as Ignored.

Make sure they are not added to Settings - Version Control - Ignored Files list.

4

Oh yes, it's been added into ignored files for some reason I don't  know. Thank you so much!

0

Dmitriy Smirnov answer worked for me perfectly in Webstorm

1

I came across this thread with a similar problem. But in my case, even though the changed files were reflected in other IDEs, it still didn't appear in the dedicated window in Webstorm. To fix this I have found some setting (which is not so clear in my opinion) to control that. If you turn this OFF, it will add the Default Changelist view.

Preferences → Version Control → Commit → Turn OFF the "Use non-modal commit interface"

That's the Changelist view:

5

otomer

Not sure why this is considered similar.

When the Use non-modal commit interface option is enabled, there is the Commit toolwindow on the left, that shows the Local Changes (where Default changelist resides) and allows committing from there. See https://www.jetbrains.com/idea/whatsnew/#version-control

Commit action (Ctrl/Cmd+K) navigates to the toolwindow.

So you don't need to disable the setting to see the changes list.

1

The solution described above solved my problem.

0

There is not `Ignored Files` in `Version Control` option. 

0

Another reason why this can happen: if you clone your local repo in a directory called ~/.git - so you would end up having ~/.git/<project>/.git - then this apparently causes issues detecting changes (version: Intellij Ride 2023.3). But who would do that, right? Well… euhum.

0

I had similar problem and I solved in a different way. 

I had to go to “Settings” → “Version Control” → “Directory Mappings” and there I had to add the directory of the project to recognize the files I changed. I had two unregistered projects.

0

I simply had to activate the option “Use non-modal commit interface” and then deactivate it again to make it work.

0

请先登录再写评论。