2018.1 EAP does not support the "esnext.promise" lib when using TypeScript versions newer than the latest stable release

Thank you Elena Pogorelova for helping me with my last related issue: https://intellij-support.jetbrains.com/hc/en-us/community/posts/360000111950-Supporting-Promise-prototype-finally-in-TypeScript-targeting-ES5- . Elena instructed that 2018.1 EAP supports the "esnext.promise" lib. I found that this was true for the latest stable release of TypeScript: v2.7.2.

However, I have found that TypeScript v2.8.x (a "@next" version release of TypeScript; not yet stable) does not support the lib. Will it be supported by the time that the release becomes stable?

0

Seems they have changed "esnext.promise" to "es2018.promise" - the former is no longer recognized... See https://github.com/Microsoft/TypeScript/issues/20342

WebStorm doesn't yet recognize them in tsconfig.json, see https://youtrack.jetbrains.com/issue/WEB-32187

1

Thank you for filing the issue, Elena!

This thread can be considered closed; further developments to be followed on the issue tracker.

0

请先登录再写评论。