Can't debug odoo, pydev debugger Process finished with exit code -1073740940


Hi gurus,

My company wants to implement an ERP and we've decided that Odoo is the chosen one.

Odoo server (debian) is running, but we need a development environment in windows which I've already installed,from PyCharm I can Run the odoo server and navigate through the browser and watch the log fill, so I think it works.

But I can't launch in Debug mode, when I try it the message in the console is:

C:\python\Scripts\python.exe "C:\Program Files\JetBrains\PyCharm Community Edition 2018.1.3\helpers\pydev\" --multiproc --qt-support=auto --client --port 57805 --file D:/devpython/vodoo/odoo-bin --config=D:\devpython\vodoo\odoo.conf
pydev debugger: process 7072 is connecting

Connected to pydev debugger (build 181.4892.64)

Process finished with exit code -1073740940 (0xC0000374)


Is there a log for this so I can try to solve the problem? or has anyone encountered the same problem?

the only "weird" thing is that the python.exe path is different from the python.exe in my virtual environment is this a problem? if so, how can I change this configuration? I already set my Run configuration and selected the interpreter in my Virtual environment. when i run the Odoo server I get this (first line): D:\devpython\vodooenv\Scripts\python.exe D:/devpython/vodoo/odoo-bin --config=D:\devpython\vodoo\odoo.conf
Which as I understand means that is running python.exe from my virtual environment, but when I try to debug launches from another python.exe.

Sorry if this is a noob question (I have the feeling it is), but I can't find an answer or a log to know more about the problem... also sorry if my english is not good.


Hi Bungunala! Yes, it looks like you're using another Python interpreter, you're right. Are you using the same Run configuration in both cases? If no, you can change the second Run configuration's interpreter in Run | Edit Configurations.


thank you Elizabeth, I configured the run configuration (pic) but I don't see any option to set a different config for debug, is there any log with the exact error? i only get that "Process finished with exit code -1073740940" but I don't know what that error means...


Hi! Yes, it's correct: if you configured Run configuration, you're using it both for running and for debugging. When you start this Run configuration under debug, does it use the correct interpreter (D:\devpython\vodooenv\Scripts\python.exe as you wrote above)? Could you please copy and paste here a starting command line both for running and for debugging with this Run configuration?


Hi Elizabeth, 

I'm not sure if this is the info you asked for

text if RUN:

D:\devpython\vodooenv\Scripts\python.exe D:/devpython/vodoo/odoo-bin --config=D:\devpython\vodoo\odoo.conf
2018-05-22 16:42:06,460 10736 INFO ? odoo: Odoo version 11.0
2018-05-22 16:42:06,461 10736 INFO ? odoo: Using configuration file at D:\devpython\vodoo\odoo.conf
2018-05-22 16:42:06,461 10736 INFO ? odoo: addons paths: ['C:\\Users\\rpalomequep\\AppData\\Local\\OpenERP S.A.\\Odoo\\addons\\11.0', 'D:\\devpython\\vodoo\\addons', 'D:\\devpython\\vodoo\\odoo\\addons']
2018-05-22 16:42:06,461 10736 INFO ? odoo: database: odoo@localhost:5432
2018-05-22 16:42:06,498 10736 INFO ? odoo.service.server: HTTP service (werkzeug) running on
2018-05-22 16:42:06,966 10736 INFO ? Will use the Wkhtmltopdf binary at C:\Program Files (x86)\wkhtmltopdf\bin\wkhtmltopdf.exe

text if DEBUG:

D:\devpython\vodooenv\Scripts\python.exe "C:\Program Files\JetBrains\PyCharm Community Edition 2018.1.3\helpers\pydev\" --multiproc --qt-support=auto --client --port 61522 --file D:/devpython/vodoo/odoo-bin --config=D:\devpython\vodoo\odoo.conf
pydev debugger: process 16252 is connecting

Connected to pydev debugger (build 181.4892.64)

Process finished with exit code -1073740940 (0xC0000374)


Hi! Yes, that's exactly what I wanted to see, thank you! Now I can see that you're using the same Python interpreter for running and debugging, but it leads to crash anyway. Could you please try to set environment variable PYDEVD_USE_CYTHON=NO (you can set it run inside your run configuration)? Does it help?


Hi Elizabeth, I tried setting the variable environment ( I hope I did it in the right place), but get the same error when I try to debug, is there a more detailed information about the exit code? I reproduced every step to set up the environment on a new machine and get the same exit code error... I might be doing something wrong but I don't know what exactly exit code -1073740940 means, but the error code (0xC0000374) is a memory heap corruption from what i've read.

Thank you for your patience!!


Hi Bungunala! Unfortunately, it can't say a lot about it until I reproduce it locally. Could you please share your project, or (if it isn't possible) to create a sample project for reproducing the bug? And share it in our issue tracker:
Thank you!


Hi Elizabeth, the project I'm trying to debug is Odoo 11, I downloaded the source code from:

I've made no changes to the source (the first thing I tried to do was debug and didn't work), I'm running windows 10 PRO (1803) 64bits,

I tried Pycharm 32 and 64 bits icons, but is the same.



I experience similar bug with Pycharm 2018.1.4

The debugger is now faulty. For all my scripts I have:

Process finished with exit code -1073741819 (0xC0000005)

Same scripts are working well with previous version of pycharm ( I reinstalled 2017.3 and my problem was fixed)



Would it be possible to provide your project/provide a sample one for reproduce? You can share it in our issue tracker:



This is true for any project. I can start a new one, with 2 lines of code and the debugger won't work.

I always got the message below.



I just installed 2018.2 EAP (built on the 6th of June) and it fixed my issue.

The debugger is again fully operational. I don't know exactly what happen with the 2018.1  but things are back to normal.




thank you for the update, good to know it's fine now!


Hi  every one,

I got the same error in 2018.3 and it doesn't work in the previous version, maybe I should install and EAP like @aksolace, I will download 2018.3 EAP 9 and give it a try and I let my replies later.

This is a picture of my version and error.

Thank a lot.



Hi Juan,

Please file the issue to, attach idea.log and a sample project, if possible.


Hi Elizabeth Shashkova and Sergey Karpov,

This issue continued in:

PyCharm 2018.3 EAP (Community Edition)
Build #PC-183.4139.23, built on October 31, 2018
JRE: 1.8.0_152-release-1343-b15 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Windows 10 10.0

I posted the issue:

Letme know if you need more details.

[EDIT] 2018-12-04 11:14

I will try with 2017.3 like Akasolace suggest.

[EDIT] 2018-12-04 11:33

I got the same error using 2017.03 Community edition:


PyCharm 2017.3.7 (Community Edition)
Build #PC-173.4674.62, built on November 14, 2018
JRE: 1.8.0_152-release-1024-b18 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Windows 10 10.0


C:\Users\JuanDiego\Documents\Desarrollo\o11\venv\Scripts\python3.exe "C:\Program Files\JetBrains\PyCharm Community Edition 2017.3.7\helpers\pydev\" --multiproc --client --port 49959 --file C://Users//JuanDiego//Documents//Desarrollo//o11//odoo//odoo-bin -c C:\\Users\\JuanDiego\\Documents\\Desarrollo\\o11\\odoo11-community.conf -d caycho
Connected to pydev debugger (build 173.4674.62)
pydev debugger: process 9968 is connecting

Process finished with exit code -1073740940 (0xC0000374)




When I include PYCHARM_DEBUG=True variable, when I debug I got this trace:

C:\Users\JuanDiego\PycharmProjects\prueba_final\venv\Scripts\python3.exe "C:\Program Files\JetBrains\PyCharm Community Edition 2018.1.4\helpers\pydev\" --multiproc --qt-support=auto --client --port 50170 --file C:/Users/JuanDiego/PycharmProjects/prueba_final/odoo/odoo-bin
Using Cython speedups
Executing file C:/Users/JuanDiego/PycharmProjects/prueba_final/odoo/odoo-bin
arguments: ['C:/Users/JuanDiego/PycharmProjects/prueba_final/odoo/odoo-bin']

Started in multiproc mode

('Connecting to ', '', ':', '50170')
debugger: received >>99 -1 50171
Received command: ??? 99 -1 50171

Received port 50171

pydev debugger: process 4820 is connecting

Connected to pydev debugger (build 181.5087.37)
('Connecting to ', '', ':', '50171')
debugger: received >>501 1 0.1 WIN
Received command: CMD_VERSION 501 1 0.1 WIN

sending cmd --> CMD_VERSION 501 1 @@BUILD_NUMBER@@
debugger: received >>101 5
Received command: CMD_RUN 101 5

debugger: received >>122 3 python-BaseException None None 0 1 0
Received command: CMD_ADD_EXCEPTION_BREAK 122 3 python-BaseException None None 0 1 0

Exceptions to hook on terminate: {'BaseException': <_pydevd_bundle.pydevd_breakpoints.ExceptionBreakpoint object at 0x000002B645A28208>}

debugger: received >>146 7 SHOW_RETURN_VALUES 0

Show return values: False

Process finished with exit code -1073740940 (0xC0000374)


I hope this can be useful to helpme solve my problem.


hello sir

i commented this in my config file

;logfile = /path/odoo-project


Thanks Exportdeveloper Web, but I don't use that line.



Hi Juan,

Please try to add the following environment variables to your run configuration:


... and check if it changes anything.


Hi  @Andrey Resler, I actually use that configuration, and I still getting the same result with or without it.




Ok, thanks for clearing that out. I will try to get a status update on that ticket submitted by you:


Thanks you @Andrey Resler.