Is there a way to hide "Declared in" popup?


In the editor, with Ctrl key down, when mouse hover over a non keyword token (e.g. variable, method, type etc), a popup occurs showing where the token is declared. Usually this appears just above the token and doesn't pose a problem.

However when the token / mouse is close to the top of the editor, the popup hides the token. Given that usually mouse click on the token is used to navigate to the declaration, this hiding makes it harder to navigate to the declaration.

Is there a way to hid this popup?



I can't reproduce this in CLion 2018.2.6 on macOS:

What CLion version do you use? On what OS?

Please provide a screencast illustrating the issue.


Thanks for checking this.

I was using Ubuntu 18.04, CLion 2018.3 Release candidate. Also I have editor tabs on the right hand side instead of top.

Just now tested with CLion 2018.2 on Ubuntu 16.04. The problem occurs when editor tabs on the right, but not when on top.

(Settings -> Editor -> General -> Editor Tabs -> Placement -> Right)



I still can't reproduce it, unfortunately. Ubuntu, tabs on the right:

The popup always appears above or below the line.

Is it possible to provide screenshot or screencast? It seems I'm missing something.


Screenshot attached. I can send a mp4 video as well if there is an e-mail.

Note that I have "Navigation Bar" disabled as well. Also the problem seem to happen with taller tooltips, 5 lines or so.


Looks like the documentation popup. Please check whether you have the following settings enabled or disabled:

File | Settings | Editor | General | Code Completion > Show documentation popup in

File | Settings | Editor | General > Show quick documentation on mouse move


Both those settings are disabled. So seems like something else.


You are just holding Ctrl and don't press anything else, right? Please send the video to clion-support at Thanks in advance!


Emailed the video. Also attached the settings export.

Yes, I just press Ctrl and hover mouse over the token.


Thanks. Looks like the same bug, though I notice it only when it is close to the top of the editor and with multiline tooltips (>4 lines).

Is there a setting somewhere to disable editor tooltips, at least the "Declared in" one? Tks.


I'm afraid it's not possible to disable this tooltip. But you can use other variants of calling the "Go to Declaration" feature (right-click > Go To > Declaration, or Navigate | Declaration on the main menu, or Ctrl+B on Linux) in order to navigate to a declaration without popup.