Open File or Project is really slow

When using the "open File or Project" dialog window, it loads the last used directory for 10-30 seconds. This is really annoying. The process is still responding if i check the task manager

Software: Phpstorm 2018.3.5.

PC specs: c: drive is 2x 850 evos in raid 0, 16 gb ram, i5-6660k @3.5ghz.

Gif example



Any ideas what this can be?


It could be a rough workaround, but there is an experimental feature that allows switching to the Windows native file chooser instead. To use it, please add the following properties to the "Help | Edit Custom Properties" and restart the IDE:

Yep, I can confirm it's because of the unavailable network drives. So for example, I'm accessing these drives over VPN, so if it's not active, loading of projects takes forever, hangs, etc. 

Please, fix it by limiting loading to just the drive items in the dialog.


Do you have any attached shares? If they are disconnected and Phpstorm scans that directory, it will hang for about 20 sec per share.

In cmd, run "net use" to see which drives are disconnected


Hi again! 
The new file chooser works very well. 
For other users who have problems with the activation of this feature: 
go to menu 
help > edit custom properties 
and add to file

Adding the installation directory to the antivirus' exclusions is not a solution, it's a workaround for the UI thread being blocked by a task which can take on the order of minutes to complete. Worse, the Open File dialog is a modal, so we can't use the app at all while we wait; we can't even cancel.

It's not even a viable workaround for many people. My organization's security team quite rightly does not grant us all permission to configure our antivirus to exclude arbitrary directories.


I found on the stockoverflow Mihai Cazac fixed his slowness by disconnecting the network drives that displayed in windows explorer as not connected. I tried, to disconnect my network drives that were shown as disconnected and I now it list directories in one second. So as work around disconnect your network drives, then open your project and reconnect your network drives. Anyway you have to wait 5 or more should be not that difficult.

Create refreshDrives.dat

net use /del Z:
net use z: \\remotepc\sharename

Confirmed, this bug is reproduced via network drives in My Computer that are not on the network.  I disabled all anti-viruses and nothing.  I finally tried turning my NAS back on, so that network drives would open - and boom, problem went away.



Do you have antiviruses? If you do - try disabling them or adding PhpStorm installation directory to its exclusions. 

No other suggestions currently other than that. 

You can also submit this at for a closer look.

If you do this please:

1) attach logs after you've reproduced the issue (Help > Show log in ...)

2) capture a CPU snapshot while reproducing the issue. Here's an article about this:




Ralf Longwitz, according to this comment, there's a chance we'll see it in 2021.3.


Hi Dmitry,

Thanks for the quick response.

After I disabled Windows Defender (Which i thought i had already done) it was working fluently. Also now my file-related console commands also run faster. So If you have Windows 10, make sure you tell it that PhPstorm should be excluded.


Well, just to try I installed 2019.2.4, in its own folder. The older version listed my projects in ONE second, seventy times faster!!!

I think, it would be good, when IDE can list projects as it finds some then scan the whole world for other projects. If it happened, the project I need on the list, I can click on it open it and the scan is cancelled. However, if need the one that is not on the list then I can wait 70 seconds for the one.

The product is awesome, I like it a lot, but this is just a suggestion. Thank you ALL very much!


@Tariqul Islam 

Thank you very much.

Your suggestion worked.
I disconnected the unused directory and it happened

sorry for my english :)


Hi! I'm using Avast and disabling the monitoring in my project folder also did the job. Thanks!


Thanks @Cjohnson223 
I'm removed all network drives. Now the dialog scans all very fast!

Is there a way to prevent scanning network drives?


I second this request! I have the same problem with the network drives in PyCharm 2021.2. I can not open any project folder if I am not connected to the company's VPN. This is a serious bug!


Well let's hope it gets fixed. This issue is abysmal and makes me hate IDEA an insane amount. Thanks for making me miss Eclipse........

What's the status? I tried to read the report but it needs a TLDR;


Thanks for an update!



2019.2 version was opening normally, after I updated to 2019.3 community version, it started doing like the above image shows, it take 70 seconds to show the list of projects.

I can't update antivirus or stop it, have not enough rights. The Help>Show log in... doesn't show anything about opening project. CPU for intellij used only 5-10%.

(Is there a quick way to downgrade to 2019.2?)

thank you.


Thank you Tariqul for quick response. I checked all 15 shares I have, and all connected. Is there a way to set scanning only c: drive and to ignore the 15 shares?

thank you.


No, unfortunately you can't limit IDE to scan only C drive.



That is going to be solved as a part of
Unfortunately, I can't provide you with any ETA. The In Progress state gives us hope though.


@Eugene Morozov Any news on the state of the development of a solution?


I completely agree with @E M Salazar Duque, I've waited 20 minutes without the file dialog ever finishing loading. This was on a VPN as well. I really don't understand why this isn't a priority, if it's actually preventing users from using the product at all.

A workaround I found was to use the command-line (, but that is just foolish that I have to do something like that to be able to open a project...


This was quite frustrating! I ran into the same issue in PyCharm.


Vasiliy Yur Yup, thank you! This fixed it for me on Windows 11. I really, really hope this is going to be fixed in 2021.3.


Having the same issue with IntelliJ IDEA. Thanks to everyone who did research on this! I'm trying to use IDEA on a company-owned device so as Dbrunner01 pointed out, any workaround that involves changing security settings is a non-starter. Vasiliy Yur's suggestion worked after restarting the IDE.


It is being worked on right now:

Fingers crossed, we can expect a new file chooser in the upcoming IDE version 2022.1.


Dovholuk, basically, you can already try the new file chooser in the 2022.1 EAP:


Hi Eugene Morozov
After today's update to 2022.1 still the same issue. Slow loading browse the local directory. :(


Zdziejowski, do you have network shares mounted in your system or some kind of 3rd-party antivirus software?