'Run with profiler' disabled on Linux in Intellij Ultimate 2019.1 (Scala)

I've been using the integrated java profiler on Linux in Intellij 2018.3.5. I've just upgraded to 2019.1 and the icon is now disabled. It's visible, just greyed out.

I've followed all the instruction here (https://www.jetbrains.com/help/idea/cpu-profiler.html) and rebooted but it's still disabled.

The project is a Scala project, with SBT but using Intellij for project imports and for building. Everything else works fine.

Any ideas how I can debug the problem further to see why the icon is showing up disabled?

评论操作 固定链接

The profiler is still working in OS X with Intelilj 2019.1 on the same project. So maybe this is just a Linux issue?

Any advice on how I can investigate what's happening?

1
评论操作 固定链接

Same for me with Java on win 10

0
评论操作 固定链接

Peter - I don't think Windows is supported for the CPU profiler. "CPU Profiler is available on Linux and macOS" from here: https://www.jetbrains.com/help/idea/cpu-profiler.html

For me it's working fine in OS X but not working any more in Ubuntu.

1
评论操作 固定链接

I have the same problem, any updates?

 

1
评论操作 固定链接

Solved this way:

 

  • Open list of Actions (Ctrl + Shift + A)
  • Choose "Maintenance"
  • Choose "Experimental features"
  • Turn on "idea.profiler.enabled"
0
评论操作 固定链接

@Evgeny "idea.profiler.enabled" isn't listed in the experimental features in intellij idea ultimate 2019.2.1 installed by jetbrains toolbox on 4.19.66-1-MANJARO linux

0
评论操作 固定链接

same issue here running Intellij Ultimate version in Linux, profiling button is grey out!!! Any idea?

0
评论操作 固定链接

This fixed it for me:

"add the configuration for the profiler using the + button in Preferences | Build, Execution, Deployment | Java Profiler?"

https://intellij-support.jetbrains.com/hc/en-us/community/posts/360003416000/comments/360000445180

 

That could really be a bit clearer. Maybe the disabled button could have a tooltip explaining it's missing a configuration.

 

0
评论操作 固定链接

Under Idea 2019.1, Linux 5.0.0-37-generic,  the suggested fix of enabling 'idea.profiler.enabled' didn't work.

The "Run with profiler" option is still grayed out. I can start and stop the Async Profiler using "Help > Diagnostic > Start/Stop Async Profiler", thought.

 

0

请先登录再写评论。