Plugin build via Plugin RunConfiguration to IntelliJ CE renders CE unresponsive


I am building a very simple plugin, and have been deploying to IntelliJ CE for testing (i am coding in Ultimate). I created my Plugin project using the IntelliJ New Project wizard, and use the IntelliJ provided Plugin RunConfiguration. When I Run, it opens CE with my plugin "installed" as expected, however within 5-10 seconds, CE becomes unresponsive with the spinning wheel. Looking at ActivityMonitor the Main process (ie. CE as loaded by Ultimate) shows the memory increasing by 1GB ever few seconds. 

Initially, I thought I did something wrong in my plugin (infinite loop, etc.) so I cloned a few plugins from Github and tried "running" them to the same effect. My computer can handle multiple IntelliJ's running (16GB of ram). I updated to latest CE and Ultimate as well (2019.1).

Any ideas about what is happening and how to make my "builds" usable? Thanks




Please create issue in and attach idea.log from _debug_ instance. Thanks.


For anyone running into this, the fix is outlined here:

It appears the instructions on IntelliJ's docs are outdated, and a special download of the IntelliJ Runtime JDK (from bintray) is required, to be used as the IntelliJ Plugin Development SDK's JRE.