Why it's updating indices again and again? making it unusable at all

已回答

The ide is "Updating Indices" of JDK, 3rd jars, .gradle/ folder etc again and again and again when openning the project.  It takes too long time, and cannot be canclled. Making IDEA totally unusable, very very very annoying!

This happening in all versions of idea with gradle plugin.

This feature must be improved, some suggestions:

(1) do not index the same thing more than once

(2) let user to define the exclude-set of indexed folders

(3) do not index unused stuffs; try to identify which are unused

(4) do not block user operations when it's indexing

etc

评论操作 固定链接

This feature must be improved!!! it makes the best IDE to the worst software in the world...

26
评论操作 固定链接

please fire the guy who made it...he is destroying the product

20
评论操作 固定链接

Hi. 

Are there any auto-generated files in your project? If so, IDEA would reindex them every time.

To exclude the folder from indexing, mark this folder as Excluded in the File | Project Structure | Modules | Sources

-15
评论操作 固定链接

I agree with Leon my pyharm just finished updating indices for 2 hours then I close and launched again and it is started indices again for hours. 

I am not professional developer or programmer I am an mechanical engineer but I do not understand the logic and need for "indices" operation. 

If it is necessary why Anaconda Navigator's Spyder does not do it. And I see a lot of complaints about it why JetBrains is not fixing it.I paid again for second year but can hardly run "Hello World" program. Can someone again explain what does tgis operation do and why other IDEs do not have it 

7
评论操作 固定链接

@H Isman

IDE does a full project index only once. Then it index only changed/added files. It is needed to let IDEA know the structure of your code which is needed to refactor code, navigate through classes etc.

What is the project type? Are there any changing files or folders with big content in the project?

Make sure you did not accidentally add some directory with many files and folders into the project, or if you have generated files inside project (output of scripts, log files etc) exclude such files (by marking file as plain text) or folders (by setting folder as excluded ) from project so IDE does not re-index them on any change.

Try also disabling 3rd plugins if you use any.

-13
评论操作 固定链接

Not funny... "Updating Indices - Indexing...", only a few files... waiting and waiting again...

PLEASE IMPROVE THIS!

Can a log tell me, what IDEA is doing the whole time? In htop, I see a lot of PIDs with ~/.local/share/JetBrains/Toolbox/apps/IDEA-U/ch-0/192.16603.28/..., but the progress bar isn't moving and my PC doesn't seem to write to disc. I don't know, if there is any real progress at all...

3
评论操作 固定链接

Hello Jochen,

Please report an issue on YouTrack attaching logs folder zipped (https://intellij-support.jetbrains.com/hc/en-us/articles/207241085-Locating-IDE-log-files) after facing the issue again: http://youtrack.jetbrains.com/issues/IDEA.

 

0
评论操作 固定链接

Hello Yaroslav,

it's easy to reproduce: create an app with some files (in my case Java EE), open it as a project in IDEA. Close IDEA.
Then change some code outside of IDEA and outside of the IDEA project directory, copy all the files with some File-Explorer (Nautilus, Windows-Explorer) and paste it in IDEA into the project. IDEA will start to index and never come back to work.

The reason I want to do this is, that we get source code as war-files and build our local archive and make diffs via git with them.

While that is an "overwrite all" with files, git will only add source code changes, regardless if the files timestamps changed. I will not search for changed files and replace them manually one by one: outside IDEA it's just copy&paste from a new temporary source-folder of the extracted war to the IDEA project folder, then a "git add -A" and "git commit [...]" in the terminal, all done in seconds for our archive to get synced to the external work. Pasting within IDEA into the project directory, my PC is getting useless, because IDEA will index without progress. I had to kill IDEA every time I tried...

1
评论操作 固定链接

Jochen,

I don't get long indexing process on my machine after pasting files. Probably some extra steps are needed to reproduce?

 

0
评论操作 固定链接

I'm seeing the indexing problem as well.

In my case, it started after my anti-virus software quarantined these files, which appear to be internal to Intellij:

:cd .IntelliJIdea2019.3/system/index/
:find . -name 'hashes*'
./.persistent/hashesWithFileType
./.persistent/hashesWithFileType.keystream
./.persistent/hashesWithFileType.keystream.len
./.persistent/hashesWithFileType.len
./.persistent/hashesWithFileType_i.len
:pwd
<My HOME directory>/.IntelliJIdea2019.3/system/index

Are these files used for indexing?

 

0
评论操作 固定链接

>Are these files used for indexing?

Yes. Please exclude IDE settings/cache directories, the IDE installation home and project files from the scan.

0
评论操作 固定链接

It happens with me also, in PHPSTORM.

Try to invalidate cache and restart.

0
评论操作 固定链接

cant believe this is happen to webstorm, im proud of picking it as my best IDE and showing off to my collegues, and this updating indicing thing jus kills my reputation...

1
评论操作 固定链接

Dayanshu W

Please also add #com.intellij.openapi.util.io.FileSystemUtil:trace in Help | Debug Log Settings and check what files are indexed in the idea.log (https://intellij-support.jetbrains.com/hc/articles/207241085). You can also submit a support ticket with the idea.log attached, so we could help to find a root cause. 

1
评论操作 固定链接

Every time a plugin is updated in Intellij Ultimate 2020.1 (and previous ones) it indexes all the maven dependencies again and again.

Why on earth any plugin update will require the index also be updated from scratch??

0
评论操作 固定链接

It depends on the plug-in. Some plug-ins do require indexing, other don't. We are currently working on the new Dynamic Plugins architecture that will make it less frequent.

1
评论操作 固定链接

Back to Eclipse

Update: seemed to be the Vaadin Designer update to 4.5.1 -> be carefull

1
评论操作 固定链接

Hi, 

 

I'm facing the same problem with PyCharm Community on Ubuntu 18.04:

 

* my project folder is /home/my_name/Downloads

* Pycharm try to index ALL the files and folders in my /home/my_name, EVERYTHING, even the .cache, .virtualenv... folders and not only in the project folder

 * so I delete everything in this folder (even the .idea folder), then I restart Pycharm

* and, again, Pycharm indexes ALL files and folders in my /home folder (see image)

Why?

 

Best regards,

 

Philippe

 

 

0
评论操作 固定链接

A question related to this comment here

What is the scope of this full index operation? My IntelliJ seems to be indexing my whole filesystem, as mentioned by Philippe Juhel. Should it be only the opened project? It is indeed really slow.

I'm on ubuntu 19.10 with IntelliJ Ultimate.

0
评论操作 固定链接

IntelliJ IDEA indexes any folder that is added to the module content roots or libraries. It could be that you've added your home folder or there is a symlink to the drive root somewhere.

-1
评论操作 固定链接

This skeleton generation strategy is the most pants-on-head stupid feature I never asked for. I simply don't know what you mean when you advise to exclude the problematic directory from the project roots. PyCharm indexes MY ENTIRE HARD DRIVE. There isn't even an OPTION to exclude ancestral directories from the project sources. The problem lies in the jdk.table.xml file, which includes the root directory of all my Python projects. But when I remove this line, it grows back immediately the next time I restart like kudzu. I HATE THIS SO MUCH.

0
评论操作 固定链接

@Kevin Zeidler

>I simply don't know what you mean when you advise to exclude the problematic directory from the project roots.

If the problematic directory is in your project, then you can right-click it and choose Mark Directory as -> Excluded.
If it's not in the project, then make sure it's not in the Interpreter Paths https://www.jetbrains.com/help/pycharm/installing-uninstalling-and-reloading-interpreter-paths.html

0
评论操作 固定链接

> If the problematic directory is in your project, then you can right-click it and choose Mark Directory as -> Excluded.
It's not - because, again, the skeleton indexes virtually my entire hard drive. Hundreds of thousands of files and directories indexed every time I start a new project. The cache inevitably grows to >50GB unless I manually delete it periodically.

>If it's not in the project, then make sure it's not in the Interpreter Paths https://www.jetbrains.com/help/pycharm/installing-uninstalling-and-reloading-interpreter-paths.html
Interpreter Paths consist solely of descendants of the project root. 

 
To reiterate, the problem lies in the jdk.table.xml file, which includes several problem directories. It is almost certainly related to this file, because when I grep PyCharm dirs for those specific strings, this is one of the only places it occurs (other than log files). I cannot delete those entries. They regenerate the next time I start PyCharm. I even attempted to revoke its write privileges to that file, but that interfered with startup and PyCharm printed an error about being unable to load settings.
0
评论操作 固定链接

Have the same issue for all maven projects

0
评论操作 固定链接

Oleksiyprosyanko

What is your OS / IDE version? Have you tried any of the solutions suggested in this thread?

0
评论操作 固定链接

OS: MacOS Catalina 10.15.6

IDE: Ultimate 2020.2.1

I have this issue for Javas project only or any other project containing Java code.  My Scala projects behaves normally. 

0
评论操作 固定链接

Please disable the Settings (Preferences on macOS) | Editor | Inspections | Java | Probable bugs | Magic Constant inspection: https://i.imgur.com/VuMYUB4.png .

It's a known bug: https://youtrack.jetbrains.com/issue/IDEA-247322 .

If your problem is different, please file a new bug at https://youtrack.jetbrains.com/newIssue?project=IDEA and provide the logs (Help | Collect Logs and Diagnostic Data).

-1
评论操作 固定链接

Did not help. I disabled all `Probable bugs` under `Java` inspection.

0
评论操作 固定链接

Then your problem is different, please follow the second part of the answer above.

-1

请先登录再写评论。