Why it's updating indices again and again? making it unusable at all


The ide is "Updating Indices" of JDK, 3rd jars, .gradle/ folder etc again and again and again when openning the project.  It takes too long time, and cannot be canclled. Making IDEA totally unusable, very very very annoying!

This happening in all versions of idea with gradle plugin.

This feature must be improved, some suggestions:

(1) do not index the same thing more than once

(2) let user to define the exclude-set of indexed folders

(3) do not index unused stuffs; try to identify which are unused

(4) do not block user operations when it's indexing



>> Could you please update to the latest version and check if the issue is still there? If it is please file a ticket and share log files with us


IDEA 2021.2.2 - it looks like the situation has become better. At least I do not remember re-indexing after each project opening last weeks. IDEA after a project opening searches for files for indexing (it takes 1-2 minutes) and checks spring configuration.

Full (and long) re-indexing remains if IDEA was incorrectly closed (killed as process, power was switched off). But I guess this is another case and it happens not so often. 

Thank you for feedback and reaction



> Full (and long) re-indexing remains if IDEA was incorrectly closed (killed as process, power was switched off). But I guess this is another case and it happens not so often. 



>>Serge Baranov

As far as I understood from your link, version 2021.2.3 fixes the issue with re-indexing (if IDEA was incorrectly closed).

I've updated IDEA to 2021.2.3. Will be tracking if the issue has gone.



Yes, this issue should be fixed in 2021.2.3.


If only the IDE would do what people are saying here "it only index once" nope, it indexes if it crashes too (which unfortunately happens quite often once you write something more than hello world)

I wish we could just disable this


Vinicius Carvalho Indexing database could be corrupted after crash, that is why we reindex. 

This will be improved a bit in 2021.3, and more improvements will be done in 2022.1 


It also indexes out of nothing too. Which is quite annoying. I was working on a class, and after saving it it started indexing, what seems to be internal jars of intellij, and I got no code completion for like 3 minutes.


Vinicius Carvalho Looks like https://youtrack.jetbrains.com/issue/KTIJ-753

For additional details please file a new report at https://youtrack.jetbrains.com/newIssue?project=IDEA and attach the logs using Help | Collect Logs and Diagnostic Data.


I had the same problem on mac Monterey 12.5 (Apple M1) with PyCharm 2022.2, each time it re-indexed the whole project in an unworkable way.
I solved it with 2 steps:
1) File -> Manage IDE Settings -> Restore Default Settings (maybe optional, in my case it was useful)
2) Preference -> Project Structure -> .idea folder mark as Excluded (mandatory)

I hope it can help someone else.



Serge Baranov I have version 2022.3 and this issue still occurs on my machine.
Not only when I do a restart or install a new plugin but even during working with the IDE it could start index indices on its own.

I've tried to follow some of the suggestions here but can't find any helpful solution to this problem.
What do you recommend?

I'm using Java 8 (sadly, should update to 17 soon), Maven 3.8.6 and Windows 11


Omri Ratson

Could you please share log files and report an issue here

That would be very helpful if you could reproduce reported scenario and collect logs after (when IDE starts indexing out of a sudden)


I experience constant reindexing of the .m2 folder, which puts huge load on my laptop.

The size of my .m2 folder is ~4.7GB, so not small but not huge either. I understand that reindexing would take some time and that's okay. But once it's done, why IntelliJ would launch it again when I changed just one small dependency. It just doesn't make any sense.

I'm running latest IntelliJ IDEA 2023.1.2 (Community Edition) on MacBook Pro 2,3 GHz 8-Core Intel Core i9

Build #IC-231.9011.34, built on May 16, 2023
Runtime version: 17.0.6+10-b829.9 x86_64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.

I'd be happy to provide logs but the application warns that logs might contain sensitive data. Since this is my working laptop, I can't really do that.

Sergey Baranov, Are there any other options how I can help with debugging this issue?



Dmitry Bigunyak Please file a bug with the logs attached.


Any update on this? The issue being that pycharm re-indexes all the anaconda / node folders even when no update is made on the external libraries, only on my project code. Why is that? could it be that my conda virtual environment is stored on Dropbox? Or a git related issue? Previously my project was the same size, using the same libraries and the indexing time has never been an issue. Now it is a major issue as I have to wait about 40 minutes any time I run pycharm. The only difference with before are the 2 aforementioned settings:

- anaconda env on a Dropbox folder

- added the project files to git.

I've already tried deleting the cache and excluding non necessary folder from my project.

Many thanks


Daniel Marin, to help us analyse your issue, please submit a YouTrack bug with collected logs (Help | Collect Logs and Diagnostic Data).


Margarita Tyumenkova , thanks for your prompt reply. Will do. Looking at the log, it seems that my Python SDK (conda env) is the one that takes the longest to index. The issue is that it repeats the indexing process anytime I open pycharm, even with no change in the project.

Will see what the bug tracker says.

Many thanks