Marketplace Plugins are not loaded

已回答

Hello, I'm working for a company and I currently have access to https://plugins.jetbrains.com/ but inside IntelliJ, when I browse the Marketplace, it says:

Marketplace Plugins are not loaded
Check the internet connection and try again

How can I configure it to be able to browse and download?

Thank you

4

It worked, but I have to reconfigure everything :(

0

Plugins are not loaded

Upload id: 2022_03_29_XDRWTU1HAGgnNycA (file: idea.log)

 

0

Ережепов Ринад Каирович The issue is caused by your proxy server, it seems to abort the connection. Try No Proxy option. If it's not possible to access the plugins repository without a proxy, contact your proxy administrator for help.

0

I can't load the list of plugins either.
I am not using Proxy.

Upload id: 2022_04_20_994ZsiM6PRsBqNUi (file: idea.log)

 

0

okamoto Can you open https://plugins.jetbrains.com/ in the web browser?

2022-04-20 13:28:38,504 [ 107885]   INFO - #c.i.i.p.PluginManagerConfigurable - Main plugin repository is not available ('Remote host terminated the handshake'). Please check your network settings.
0

Thanks for the reply.


It shows up fine in my browser.
However, I can't seem to access it in Pycharm.

As a connection test, I enter `https://plugins.jetbrains.com/ ` into the `Check connection` dialog and it does not connect.

Other URLs, for example `https://google.com/ `, can connect.

Also, I reinstalled and initialized the IDE, but it does not change.

0

okamoto Do you have any firewall/security tool running on this system which can affect network connections per application? It could be that something is blocking PyCharm. See if you can reproduce it on any other system.

0

I am using the standard MacOS Monterey Firewall.
I have disabled it, but cannot access it from the IDE.
I do not use any other security tools.
Also, pings from the IDE's Terminal seem to arrive normally.
I have no idea what is going on.

```

% ping plugins.jetbrains.com

PING plugins.jetbrains.com (18.65.148.74): 56 data bytes
64 bytes from 18.65.148.74: icmp_seq=0 ttl=242 time=37.221 ms
64 bytes from 18.65.148.74: icmp_seq=1 ttl=242 time=38.003 ms
64 bytes from 18.65.148.74: icmp_seq=2 ttl=242 time=62.929 ms
64 bytes from 18.65.148.74: icmp_seq=3 ttl=242 time=57.520 ms
64 bytes from 18.65.148.74: icmp_seq=4 ttl=242 time=51.022 ms
^C
--- plugins.jetbrains.com ping statistics ---
5 packets transmitted, 5 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 37.221/49.339/62.929/10.294 ms

```

0

Please add -Djavax.net.debug=ssl in Help | Edit Custom VM Options, restart the IDE, reproduce the issue and upload the new idea.log file.

0

File sent.

Upload id: 2022_04_20_Dt9BbkdYj1gahViF (file: idea.log)

0

okamoto Try adding -Dhttps.protocols=TLSv1.1,TLSv1.2 in Help | Edit Custom VM Options and restart the IDE. If it doesn't help, change -Djavax.net.debug=ssl to -Djavax.net.debug=all, restart the IDE again and provide the log with more debug information.

0

Thank you for your response.
By adding `-Dhttps.protocols=TLSv1.1,TLSv1.2`, I was able to get the list of plugins successfully.
At the same time, the issue of the license information not being displayed has been fixed.
Is this a MacOS problem?
it is a problem with my settings
Is there a fundamental solution to this problem?

0

okamoto The issue is not clear, could be some transparent proxy in between you and JetBrains servers.

0

My logs:
Upload id: 2022_04_29_CJ67gg2WkxbpDjyD (file: idea.log)

I started hitting this on the last few EAP builds of Rider 2022.1 and with the final release.

0

Thank you, deleting the cacerts file made it go back to prompting me to accept the cert and see the plugins. (Corporate man-in-the-middle, re-signed certificates are sub-optimal...)
I do get this error notification, as well, though:
Failed to load plugins from 'https://plugins.jetbrains.com/': org.xml.sax.SAXParseException; lineNumber: 1; columnNumber: 3; The markup in the document preceding the root element must be well-formed.

0

Jmorton Please share the new logs.

0

My problem is slightly different. Hope you find a way to help me.

I cannot see the details when I type the Python to the marketplace section in the Plugins. So the right side of the window which normally should show the installation button and explanations about the python plugin can not be visible. please see the attached picture. I have tried with another computer but the same problem also continues on it. can you help me,

0

Same as @Fehmiselcuk06, I have the list of plugins but when i select one it can't display the content of the plugin or install it..

1

Fehmiselcuk06 We need the logs to investigate the issue. Please open a ticket at https://intellij-support.jetbrains.com/hc/requests/new and attach the zip with the logs using Help | Collect Logs and Diagnostic Data.

0

Hi, I've got 403 error. this happened after my phpstorm license was removed. but I'm using IDEA community version,  it shouldn't be affected? how to fix it?

The logs shows: 2022-06-10 12:38:11,721 [ 603059]   FINE - #c.i.u.i.HttpRequests - response from https://plugins.jetbrains.com/api/icon?pluginId=Osmorc: 403

If I directly open the link https://plugins.jetbrains.com/api/icon?pluginId=Osmorc in browser, it's also 403 error.

 

0

Serge Baranov should I still open a ticket. It seems there are lots of tickets logged this morning.

0

Fehmiselcuk06 No, it's a known issue and our team is working on it.

0

Serge Baranov thank you. How long does it take to be fixed typically?

0

Fehmiselcuk06 We cannot provide any ETA at this point, sorry. Our marketplace team is mostly in the EU time zone and they are not available at the moment. It may take several hours.

1

@Fehmiselcuk06 This issue should be fixed. You could download the plugins now.

1

Serge Baranov could you pls help i did everything from here but still no luck

 

0

Sikderi, please file a ticket to support with the logs attached.

0

请先登录再写评论。