Vue.js version 3 support

Vue.js has plans to release version 3 in Q3 of 2019. Remembering that support for Vue.js 2.x in Idea comes out with huge lag, should we expect timely update of Vue plugin when v3 releases?

 

By supporting Vue I mean support at least of everything that comes in a typical project with standard ecosystem: Vue, Vuex, Vue-router, Vue-cli, etc.

评论操作 固定链接

IDEA does already support Vue 3.x... What problems making it work have you faced?

0
评论操作 固定链接

Great, I'll check it out once Vue 3 releases.

 

I mean support of Vue and default ecosystem was pretty limited first months since Idea got support. Especially compared to language server + VS Code. I'm glad it's much better now and it is better than VS Code's plugin.

0
评论操作 固定链接

For example the code hints do not work in composition API (setup() {...)

code hints do work in options API

computed:{
this.$store.getters.get
}

but not in composition API - check the screenshot below.

setup(props){
...
return {
uiLayoutComponentName:computed (()=> store.getters.get),
}
},




0
评论操作 固定链接

Initial Vue 3 support can be expected in the upcoming IDEA 2020.3
Note that the specification is not yet finalized, see https://youtrack.jetbrains.com/issue/WEB-47799#focus=Comments-27-4446196.0-0 for more info

Please try upgrading to 2020.3 EAP, if it doesn't work for you there, create a support ticket, providing a minimal sample the issue can be repeated with

0

请先登录再写评论。