Scene Builder does not work anymore after update to 2019.2 version

已回答

I installed that major update yesterday and now the scenebuilder for fxml files does not work anymore. I opened an entire new project and created just one test file something.fxml for testing. The scenebuilder gives an error message:

java.lang.ClassNotFoundException: com.sun.javafx.fxml.LoadListener PluginClassLoader[org.jetbrains.plugins.javaFX, 192.5728.98] com.intellij.ide.plugins.cl.PluginClassLoader@17bf8672

java.lang.NoClassDefFoundError: com/sun/javafx/fxml/LoadListener

com.intellij.diagnostic.PluginException: While loading class com.oracle.javafx.scenebuilder.kit.fxom.FXOMLoader: com/sun/javafx/fxml/LoadListener [Plugin: org.jetbrains.plugins.javaFX]

Any suggestion?

评论操作 固定链接

I have the same problem...

7
评论操作 固定链接

I am facing the same issue.

 


java.lang.ClassNotFoundException: com.sun.javafx.fxml.LoadListener PluginClassLoader[org.jetbrains.plugins.javaFX, 192.5728.98] com.intellij.ide.plugins.cl.PluginClassLoader@4b8679ea

java.lang.NoClassDefFoundError: com/sun/javafx/fxml/LoadListener

com.intellij.diagnostic.PluginException: While loading class com.oracle.javafx.scenebuilder.kit.fxom.FXOMLoader: com/sun/javafx/fxml/LoadListener [Plugin: org.jetbrains.plugins.javaFX]

4
评论操作 固定链接

com.intellij.diagnostic.PluginException: While loading class com.oracle.javafx.scenebuilder.kit.fxom.FXOMLoader: com/sun/javafx/fxml/LoadListener [Plugin: org.jetbrains.plugins.javaFX]

 

same problem 

2
评论操作 固定链接

Same problem... Is it a bug?

2
评论操作 固定链接

Same problem here...

2
评论操作 固定链接

Is there a workaround by now?

1
评论操作 固定链接

Exact same problem here. Hoping for a solution soon as in the middle of a project

1
评论操作 固定链接

Did anybody find a fix for this yet?

0
评论操作 固定链接

We also have the same issue.

 

0
评论操作 固定链接

I have the same issue. 

 

0
评论操作 固定链接

Same issue, for some reason the LoadListener for the plugin is expected in a different package than it is. The question is just: why and how do I fix it?

0
评论操作 固定链接

When I raised the issue on July 26, I received the following recomendation from jetbrains as a work around:

"Use external scene builder or try switching IntelliJ IDEA Runtime to 1.8 version per https://intellij-support.jetbrains.com/hc/articles/206544879 .

https://bintray.com/jetbrains/intellij-jbr/download_file?file_path=jbrsdk-8u212-windows-x64-b1586.9.tar.gz .".

I did load eventually the JDK version 1402 using the "Get JB SDK from Bintray” function. That helped and the scene builder was back in business, although I an not quite sure, if I am working with an old version of SDK for IntelliJ IDEA now.

2
评论操作 固定链接

You can right-click on FXML files and then select open with scene builder from that menu. 

0
评论操作 固定链接

Same here. @JetBrains - please comment or post a workaround...

0
评论操作 固定链接

I have de same problem

 
0
评论操作 固定链接

Any official words out yet? I'm also facing this issue.

0
评论操作 固定链接

All you need to do is to install a custom JDK 8 (I prefer Liberica JDK 8), and switch your boot JDK by doing Ctrl+Shift+A, then searching for "Switch Boot JDK", and then select the path to your JDK 8. 

 

This version of the JDK is the ONLY WORKING ONE with Scene Builder of IDEA 2019.2 and 2019.2.1, do not attempt with JDK 11 or 12. I hope JetBrains fix this.

6
评论操作 固定链接

Thank you for the report. Please follow the issue created for this problem at YouTrack: https://youtrack.jetbrains.com/issue/IDEA-209562

0
评论操作 固定链接

You can use the standalone Scenebuilder in the mean time guys.

https://gluonhq.com/products/scene-builder/

0

请先登录再写评论。