Not able to set breakpoints on remote GDB deubgging from local machine

I am running qemu on my local machine with the -gdb flag. The code I was running can be found here: The qemu gdb server is listening on port 26000 (once again on my local machine). Then using a remote gdb debugging configuration in Clion, I am able to get the debugger to connect to the qemu session. 

But the problem is that whenever I try to place a breakpoint, I get a message saying "no source file named <name of the source file>"

I am running both qemu and Clion on my local machine (Ubuntu 18.04.3). 

I have the following debugging configuration: 


Whenever I try to place a breakpoint, I get the following message:


For the record: Xavier Monset had a scenario involving three devices, we have a tutorial for this scenario -

For everyone else who comes to this thread: please enable debugger logging as described here, reproduce the issue and send the resulting idea.log file (`Help | Show Log in ...`) to clion-support at Do not forget to disable debug logging after that. Note that logs might contain private user's information (like file paths and names). 

I run into the same problem here. Anybody has a solution to this? I need this to be solved urgently. Thanks in advance!


I run into the same bug with remote gdbserver.
When the debugger hit a crash, it's working fine. But the breakpoints don't work...



May be someone has any advice ?
Thanks !