IntelliJ Plugin Error: Plugin "Python" is incompatible (target build range is 192.7142 to 192.*).

已回答
 
 
 
 
 
 
 
 
 
 
692/5000
 
 
 
I updated IntelliJ 2019.3 Build #UI - 193.5233.102 on November 27, 2019, but the Python module, through which I had also imported the django framework, no longer works, the following error appears in the message:

Plugin Error
"Python" plugin is incompatible (target build range is 192.7142 to 192. *).
"LiveEdit" plugin is incompatible (target build range is 192.6262 to 192. *).

Error Loading Project: Django Cannot load facet (gessitrans)

I am currently developing a project that involves the Python module with Django framework.

Is there any solution to fix this error? Will IntelliJ stop supporting the Python module? Thank you.

Greetings,
- Amílcar Fernandes
2

Thanks for the update, Liubov.  I'm pretty surprised that a major release would ship without supporting JetBrains' own Python, Kotlin, Go, and Scala plugins.

If I uninstall and reinstall the Python plugin, will I lose any project settings & environment settings associated with Python?

2

It's a known issue, when compatible plugins are seemed to be incompatible, it's fixed, the solution will be available in the next EAP version.

1

Does this mean that no-one using Python should upgrade to this Idea version at all, that we should wait for the next one?  "It's fixed, the solution will be in the next early access update" suggests that there will be no fix for the current release, but only a later one.

1

This is one of the main reason why you should never blindly update your IDE. For example on when you attempt updating to IDEA 2019.3 there is a message that showing incompatible plugins with the current build, and in this case the plugins are: Python, Apache config, LiveEdit, EduTools, Idealog, Kubernetes. From my point of view, that is way too many plugins that incompatible. Especially the Python plugin, an absolute must have in today's  world. I won't update until they have made sure that everything works. 

1

Please check plugin now, the compatibility should be restored. I'd recommend to uninstall it and then install back.

1

It will be available in the next EAP version.

 

0

I do understand that the next early access release will have the fix.  For those of us not in the early access program, when might we expect to see it?  Will there be an update to the current release, or will we have to wait for the next release?  If the next, when might that release come out?  I cannot upgrade to a release that breaks the one plugin that I use every day.

0

I'm getting this same error on DataSpell.

0

Mickzeller This error has been fixed 2 years ago, your case seems to be similar, but not the same. 

Please share the whole error after updating all the plugins. 

0

请先登录再写评论。