Symbol lookup no longer finding Python field definitions


When I search for a symbol (cmd-option-o on my Mac), and type a Python class's field, IDEA no longer finds the definition. For example, my `NamedDistribution` (Django) class has a `family` field, but when I search for "family" (no quotes), I do not see that field in the results. I do see the sqlite3 database column from the Django ORM mapping, and I see functions with that term in them. I think this was working fine until recently, though I don't know what specifically changed. I naively tried "Invalidate Caches/Restart", but no luck. Any advice would b really welcome!



IntelliJ IDEA 2019.3 (Ultimate Edition)
Build #IU-193.5233.102, built on November 27, 2019
Licensed to xx
Subscription is active until December 19, 2019
Runtime version: 11.0.4+10-b520.11 x86_64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Mac OS X 10.11.6
GC: ParNew, ConcurrentMarkSweep
Memory: 1981M
Cores: 8
Non-Bundled Plugins: org.jetbrains.plugins.localization, Pythonid, R4Intellij, Statistic, com.andrewbrookins.wrap_to_column, net.ashald.envfile, org.toml.lang, ru.adelf.idea.dotenv




Perhaps I'm doing something wrong, but I don't see the difference between 2019.3 and previous versions.

Could you provide a code snippet for reproducing?


Hi Sergey. I don't think it's due to a change in versions. I was thinking it's caching-related or something local like that, but I tried 2019.3 on one Mac, and 2019.2.4 on a second Mac, and I get the same behavior: Searching for the symbol "family" does not show the class variable in the results - please see the screenshot.

Maybe I've been overdoing mind-altering drugs (ha) but I'm pretty sure this worked in the past. Q: Is/was it a feature that symbol search includes Python class variables?



Hmm, can't say the same.

As far as I remember it never searched for variables inside functions/classes.
I guess Find in Path is a better feature for that