Android support in IDEA 2020.1 Ultimate is gone. (?)

已回答

So for years I was using IDEA and keeping up with updates. I work on a web/mobile project. Thus I use IDEA Ultimate as a single IDE for everything. However after updating to version 2020.1 the support for Android has vanished. The Android project is not recognized, there is no Android SDK option in Project Structure / SDK and nothing works in Android project anymore. Has the support for Android been dumped from IDEA Ultimate 2020.1? Or is this a bug of some sort. There is no option to make a new Android project either. Are we being forced to use multiple IDS now? Thanks.

评论操作 固定链接

Please double check Android plug-in is still enabled in your IDE Plug-in settings:

0
评论操作 固定链接

I've got the same problem.

The android plugin is enabled.

0
评论操作 固定链接

With Android plug-in enabled all the options are available:

Please share the logs: https://intellij-support.jetbrains.com/hc/articles/207241085 . You can upload them at https://uploads.services.jetbrains.com/.

0
评论操作 固定链接

I have it enabled. No joy.

OSX 10.14.6 (18G1012)

0
评论操作 固定链接

https://youtrack.jetbrains.com/issue/IDEA-237177 << I filed a bug. Awaiting fix. Turns out I am not the only one who experience this problem.

1
评论操作 固定链接

I reinstalled IDEA. Now it can create / recognise android project. But "Tool | Android" menu is missing. I can find it in "Preferences | Appearance & Behavior | Menus and Toolbars" setting. I tried to create a shortcut for "Sync Project with Gradle Files" action. But it didn't execute.

0
评论操作 固定链接

 Denvoko I tried a re-install too. But it did not help. (I am on OSX). When I am on build.gradle file I do get the icon for the Sync Project with Gradle, but it does not do anything because Android plugin does not see to be loaded, though it is checked under plugins. The bug reported above has been assigned right now. I am back on 2019.3 for now and hopefully fix in 2020.1.X will be coming soon. Or maybe we will have to wait till 2020.2 whenever that comes out. 

0
评论操作 固定链接

Denvoko After a troubleshooting session with Serge Baranov we found a solution. At least for me. In my case. The ~/Library/Application Support/JetBrains/IntelliJIdea2020.1/plugins/ directory contained android-reactor-intellij-plugin.jar file. After removing it, and ~/Library/Application Support/JetBrains/IntelliJIdea2020.1/disabled_plugins.txt I restarted IDE. When it came back I was able add the Android SDK (there was none listed from previous 2019.3 setup for some reason) and after that the Android project loaded successfully. Hope this helps.

0
评论操作 固定链接

Same problem here, i.e. after updating to 2020.1 the support for Android is gone in my Intellij. The project is not recognized, so no Android SDK option in Project Structure and no Android Support Plugin in installed plugin list.

Technical Details:
- OSX 10.15.4
- IntellijIDEA Ultimate Edition

A U Nikiforoff the workaround described by you didn't worked for me, namely the file android-reactor-intellij-plugin.jar was already gone from plugins folder, but disabled_plugins.txt I removed myself.

0
评论操作 固定链接

Try removing all the non-bundled plug-ins.

0
评论操作 固定链接

A U Nikiforoff

The plugin directory doesn't contain android-reactor-intellij-plugin.jar on my computer. But deleting the plugin directory works for me. Thank you.

0
评论操作 固定链接

I have absolutely the same problem. After update 2019.3 -> 2020.1 Android plugin and projects don't work normal.

0
评论操作 固定链接

Sergey Volk does it help if you delete the plugins directory and disabled_plugins.txt file as described above?

0
评论操作 固定链接

Orif N. Sergey Volk android-reactor-intellij-plugin.jar is a third party plugin that I had. Perhaps you guys have some other third party plugins that cause the problem. Move them all to another directory and see if it solves the problem. Then add them back one by one. It would be nice to know what other plugins cause this problem so that JetBrains crew can flag them as incompatible. 

0
评论操作 固定链接

The same for me, I tried to disable all third party plugins, next i uninstalled it, after that i tried to remove ide settings.

Next I did fresh install, and still nothing.

0
评论操作 固定链接

Serge Baranov A U Nikiforoff I deleted everything (one by one) and it doesn't help. I did the same as Kamil Kalisz. Sad that I paid for Ultimate version and can't update it without problem....

0
评论操作 固定链接

Please share the logs using Help | Collect logs and diagnostic data.

0
评论操作 固定链接

I have the same problem. Anything related to android is gone.

0
评论操作 固定链接

Deleting third-party plug-ins is known to help.

0
评论操作 固定链接

I'm having the same issue. I've removed all the downloaded plugins, still no luck. After restarting IntelliJ the Android plugin is marked as "enabled" but it's in fact disabled (can't run any app or create new projects).

EDIT: I managed to let the Android plugin work by removing the `disabled_plugins.txt` file inside:

~/Library/Application Support/JetBrains/IntelliJIdea2020.1

Though that took several runs as the `disabled_plugins` file was recreated several times. 

0
评论操作 固定链接

same issue with windows ... but can't find the jar nor the disabled plugin text. got a demo tomorrow and needed this fixed ASAP

0
评论操作 固定链接

Nomar Morado What OS do you use? Which directories did you check for the plug-ins and for the disabled_plugins.txt file?

0
评论操作 固定链接

Nomar Morado try removing all plugins from ~/Library/Application Support/JetBrains/IntelliJIdea2020.1/plugins/ (or the equivalent directory if you are on windows) and remove ~/Library/Application Support/JetBrains/IntelliJIdea2020.1/disabled_plugins.txt (if present, again see what the equivalent directory is on windows, if you are on windows). Then restart IDE. Once it comes up open the Android project. At this point it may not recognize it. Go to Project Structure / Platform Settings / SDKs and add android SDK by pointing to the root directory where your Android SDK is. Restart IDE. After IDE is running again open your Android project and re-sync the gradle by clicking the circles button on the Gradle tab. The tool tip for that button is "Reimport all gradle projects". This should do it for you.

0
评论操作 固定链接

Windows 7 Enterprise Ed

Users/UserID/AppData/Local/JetBrains/IntelliJIdea2020.1/plugins

 

directory is empty

0
评论操作 固定链接

If the app was installed via Toolbox check this directory for the plug-ins:

C:\Users\UserID\AppData\Local\JetBrains\Toolbox\apps\IDEA-U\ch-1\201.6668.121.plugins\

The actual location will be visible in Help | Edit Custom VM Options after

-Didea.plugins.path=

 

0
评论操作 固定链接

Nomar Morado Also, Local is for caches directory, plug-ins are in Roaming:

C:\Users\UserID\AppData\Roaming\JetBrains\IntelliJIdea2020.1\plugins

See https://www.jetbrains.com/help/idea/2020.1/tuning-the-ide.html#plugins-directory

And disabled_plugins.txt would be in the config directory:

C:\Users\UserID\AppData\Roaming\JetBrains\IntelliJIdea2020.1

So, it appears you were looking in the wrong location?

0
评论操作 固定链接

so I renamed plugins to plugins.old. there was no disabled_plugins.txt. I started IntelliJ but got this error - Missing essential plugins: com.intellij.java and com.intelli.java.ide. Please reinstall from scratch.

0
评论操作 固定链接

Nomar Morado You should never rename IDEA_HOME\plugins. It contains the essential bundled plug-ins. You only need to check the locations specified above for the non-bundled plug-ins.

0
评论操作 固定链接

so found it under Roaming. but every time I start IntelliJ - the file shows up again?

0

请先登录再写评论。