Virtualenv activation in terminal tab does not work correctly


Hello. I'm using the latest Ultimate version and trying to set up a Django development environment in the IDE. 

I set up project SDK to existing virtualenv, but the terminal activates the wrong virtualenv, indicating the correct name. As a result, I can't install packages with pip via terminal, run commands etc.

Thanks for your response!

Screens attached:

评论操作 固定链接


unfortunately, it is not supported for now. There is a YT ticket that you can track: PY-22067

评论操作 固定链接

Is this still not supported? (IntelliJ 2021.1.3)

The checkbox is there (Settings/Tools/Terminal/Activate virtualenv), but it does not work in IntelliJ. (It works in PyCharm)