Frequent freezes and crashes in Ubuntu 20.04

已回答

Hi,

I have very frequent crashes (rendering pycharm unusable) with a new machine that runs on ubuntu 20.04. I'm on kernel 5.4.0-29-generic

This is the log:

#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x00007f6000c7a9f6, pid=76770, tid=76807
#
# JRE version: OpenJDK Runtime Environment (11.0.6+8) (build 11.0.6+8-b765.40)
# Java VM: OpenJDK 64-Bit Server VM (11.0.6+8-b765.40, mixed mode, tiered, compressed oops, concurrent mark sweep gc, linux-amd64)
# Problematic frame:
# C [libc.so.6+0x499f6]
#
# Core dump will be written. Default location: Core dumps may be processed with "/usr/share/apport/apport %p %s %c %d %P %E" (or dumping to /home/carst/core.76770)
#
# If you would like to submit a bug report, please visit:
# http://bugreport.java.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#

--------------- S U M M A R Y ------------

Command Line: -Xms128m -Xmx1949m -XX:ReservedCodeCacheSize=240m -XX:+UseConcMarkSweepGC -XX:SoftRefLRUPolicyMSPerMB=50 -ea -XX:CICompilerCount=2 -Dsun.io.useCanonPrefixCache=false -Djdk.http.auth.tunneling.disabledSchemes="" -XX:+HeapDumpOnOutOfMemoryError -XX:-OmitStackTraceInFastThrow -Djdk.attach.allowAttachSelf=true -Dkotlinx.coroutines.debug=off -Djdk.module.illegalAccess.silent=true -Dawt.useSystemAAFontSettings=lcd -Dsun.java2d.renderer=sun.java2d.marlin.MarlinRenderingEngine -Dsun.tools.attach.tmp.only=true -XX:ErrorFile=/home/carst/java_error_in_PYCHARM_%p.log -XX:HeapDumpPath=/home/carst/java_error_in_PYCHARM.hprof -Didea.paths.selector=PyCharm2020.1 -Djb.vmOptionsFile=/home/carst/.config/JetBrains/PyCharm2020.1/pycharm64.vmoptions -Didea.platform.prefix=Python com.intellij.idea.Main

Any idea on how i can fix this?


BR

 

Carst

8

Did someone solved this issue? Ive been through all related posts here and on other threads and did everything.it worked for a while and back on crashing. Im running out of options and dont want to change IDE plz.

0

Hello Shaiedri850

 

Please submit an issue at  https://youtrack.jetbrains.com/issues/PY  and upload 

logs folder zipped from ***Help | Collect logs and Diagnostic Data*** for investigation. 

0

Hi Antonina Belianskaya, thanks. But I was confused between issues. I have the same issue, but on  INTELLIJ IDEA.

could you direct me to relevent track so I could upload logs please? thank you

0

I'm with the same issue on Ubuntu 22.04 with Intellij Community Edition.

0

Brunosousa357 Does the issue occur on the latest version available via the Toolbox App

If it does, please create a new report at YouTrack providing the logs - https://youtrack.jetbrains.com/newIssue?project=PY

0

请先登录再写评论。