How do I disable Documentation in-place rendering?


I can disable the gutter icon for Documentation in-place rendering but this only removes the gutter icon but does not disable the in-place rendering of documentation comments.

I want to disable this feature: ie. no in-place rendering and no icon.

I am running SNAPSHOT build from intellij-community master, which I am guessing would probably be official EAP



File | Settings | Editor | General | Appearance, Render documentation comments — disable.


I noticed this happening too, but only for library dependencies. It turns out it had its own Rendered documentation comments checkbox, in Editor > Reader Mode.


Owen9825 We are collaborating on how to make it more clear from UX point of view. See for details.