GoLand after update has weird mouse events. (arch linux)


I'm running on manjaro linux using I3WM. I've already noticed in the past that context menus and floating windows act weird in golang, but I didn't expect it to play nicely with i3wm's tiling.

latest updated messed up something with how the ide handles mouse events that made it unusable, I turned back to MS's Code until I find a solution.

the problem:

It feels like there's always a left click pressed. hovering with my mouse moves the text cursor across lines, clicking with my mouse one time start selecting until I click again. this is like this for the editor and the output menu.

I tried restarting the app or my laptop. also I'm sure it is not an hardware issue since all other apps work perfectly.

my build info -

GoLand 2020.1.3
Build #GO-201.7846.93, built on June 3, 2020
Runtime version: 11.0.7+10-b765.53 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
Linux 5.4.46-1-manjaro
GC: ParNew, ConcurrentMarkSweep
Memory: 1900M
Cores: 8
Registry: ide.completion.variant.limit=500, suggest.all.run.configurations.from.context=true, ideFeaturesTrainer.welcomeScreen.tutorialsTree=TRUE
Non-Bundled Plugins: com.intellij.tasks, name.kropp.intellij.makefile, PythonCore
Current Desktop: i3


Hi Danlil, issue seem to be resolved, not sure how. if it happens next time I'll collect logs.


you can close this thread.



Can you please collect the logs (Help | Collect Logs and Diagnostic Data) and send them in support (Help | Contact Support)?

On which version of GoLand did everything work correctly? Have you tried doing a clean installation of the IDE or resetting to default?

I look forward to hearing from you.