ammonite support, broken $ivy imports

I've tried to use the support for ammonite scala scripts without any luck when it comes to importing ivy libraries. I've tried with a plain scala, sbt and mill project. I've always set in the scala /worksheet to treat .sc files as always ammonite. My simple ammonite script is:


import $ivy.`org.apache.commons:commons-io:1.3.2`

println("Hello world")

I am getting a "Cannot resolve symbol `org.apache.commons:commons-io:1.3.2" on the first line but when I press alt-enter and "create library from jar" nothing happens.


I've tried even using the build system to import the library and though I can see the library imported in the "External libraries", I can't use it in the script with the classes marked as not in the classpath.

When I type

import DemuxInputStream

and press ctrl-space , the import dissapears.


Seems to me the ammonite support is broken , any ideason what to do?


I've also had trouble getting this to work.


I observe this problem for many months.


I ran into this problem too and would appreciate any tips. Please vote for this issue if you're experiencing this too.


one year later, and i am having this problem with latest version 2021.2.1 - not much point in having any ammonite support if it doesn't manage this


any plans to solve this?

old versions of IDEA did work ok.