Automatic upload failed: unknown scheme "sftp" in URI "sftp://********/".



I'm running experiments on remote server, I deployed the project first configuring SSH via pycharm settings, then configuring deployment sftp also in the pycharm settings.

Everything went well for few weeks, then some big file didn't transfer and made the pycharm program stuck, I had to force-quit it and after starting up the project again and trying to upload the same file to the server the following showed up:

Automatic upload failed: unknown scheme "sftp" in URI "sftp://*****@*****.***.**.***.**".

Tried to reconfigure everything and restart the program many times. Nothing works, also tryied to remove pycharm helpers on remote host, hoping that somehow it's related to the problem and pycharm will reset everything back. 

Any ideas how to make deployment work using pycharm? Thanks! 



Please open Help > Diagnostic Tools > Debug Log Settings... and add #com.jetbrains.plugins.webDeployment and #com.intellij.ssh lines.
Reproduce the issue and file a ticket to attaching idea.log file from Help | Show Log in...


I had the exact same problem, only that it didn't occur after any  crash but just randomly. For me, it could be fixed by doing the following:

1. Downgrading to the previous Pycharm version
2. go to Settings > Deployment > Options where it would tell me that there is no default server configured.
3. Go back to Settings > Deployment and right-click on one of the setting configurations in that list and select "Use as default".
4. After that worked I updated Pycharm back to the latest version and it still worked.

I don't have any explanation why that worked, it just did, at least for me.