how to disable autocomplete on strings

I don't want any suggestion while typing strings. How can I do this? I have added a video for a better explanation.

Thanks.

 

https://www.youtube.com/watch?v=bnRmSTNxa7Y 

0

Completion auto popup for untyped string suggestions can be disabled by setting registry (Help | Find Action..., type Registry... to open it) option js.words.completion.prefix.for.autopopup to some large value, see https://youtrack.jetbrains.com/issue/WEB-48502#focus=Comments-27-4575797.0-0

 

0

Elena Pogorelova I don't have this option.

0

@bomi

>Fix versions: 2020.3.1

Looks like this will be available in next minor version: 2020.3.1 (EAP build should be available next week).

0

i keep having same problem with 2023.3.4 version of intellij idea. Is there way to disable it? Could not find `js.words.completion.prefix.for.autopopup` in the registry or any similar name in case it was renamed. 

It bloats the intellisense too much and relevant suggestions from typescript literals tend to be at the end of the list.

0

Please could you share a video recording of the issue? Do these suggestions appear on typing, or when you invoke the code completion explicitly with Ctrl+Space?

0

they appear only when i hit ctrl+space. The video would be the same as the initial author of this thread, but here is screenshot of what it suggests to me:

- names of components as text
- html tags as text
- property names somewhere in the codebase (sometimes)
- json values from mocked objects
- external things from node_modules i have never seen even in non-latin characters

If i scroll all the way down, there is possibility (if virtual list items count is not exceeded (i presume)) that typescript literals are at the end and they are actually the only things relevant, as definition of `variant` is 

```
export type ButtonVariant = "solid" | "outline" | "hyperlink"
```

Is there a property that i can use to turn off the text suggestion as was declared above via js.words.completion.prefix.for.autopopup which is missing currently in intellij idea 2023.3.4?

0

Showing these suggestions on hitting Ctrl+Space within quotes is expected, but they normally appear in the bottom of the list, after valid types. Do you have a sample project you can share that reproduces the issue?

0

tried to create minimal reproducible repo, but had no “unluck”. My assumption is that this only happens once the project gets big 

enough.

The closest i could get was trying to get autosuggestion for string in id (see screenshot). 

Variants from typescript were suggested as expected, but for some reason there was no [X] mark as in the comment above it

From what i can gather, somehow intellij mistakes typescript string literal for text and offers different suggestions based on that.

On other note, i dont even know why it offers text suggestions from object example which is basically just exported const array of 

```export const data = [
{
    "n": "1",
    "id": "4ddb4d90-d8ba-47bf-a8ff-e62f399a4876",
    "name": "Trenton Krumm",
    "address": "Appearing St 2994, Fisty, Bahrain, 666577",
    "birthDate": "15.10.2013",
    "email": "tandy_lanierw3ez@organic.nxf"
},

]

```

0

i dont even know why it offers text suggestions from object example which is basically just exported const array

It just shows string literals found in project here.

0

请先登录再写评论。