PHPStorm Updating Indexes doesn't stop

While I use PHPStorm it suddenly stars to update indexes and just doesn't stop...

This problem was happening to me when I was using PHPStorm 2020.2.3, and updating to 2020.3 EAP solved the problem for me, there aren't any updating indexing problem on 2020.3 EAP.

But this morning it said 2020.3 EAP is no longer in use, so I updated to 2020.3 and this updating indexes problem started again!

I can use it without a problem for 10-15 minutes, after that it stops me from writing code and starts to update indexes. I can't do anything while it is doing that.

I waited like 2 hours, it didn't finished the indexing. I've tried invaliding caches/restart and it didn't work either.

 

Please help me, I can't use the IDE.

7

It is hard to say anything for sure without checking log files and project first.

Is there any chance that you have files/directories that may be changed externally? 

0

I have the same issue

0

Oleksander, it makes little sense to write that in a forum thread. Please submit your logs (Help | Collect Logs and Diagnostic Data) within a support ticket (Help | Contact Support), we'll take a look.

0

When it happens menu don't work. I need only delete process

0

It's no problem if you submit them after restarting the IDE, the events will still be there.

0

Hi, I am having the same problem, how can I get a stable solution for long term?

3

Hi, on PhpStorm windows (Ubuntu) I am installing a Magento docker and the Updating indexes is locking every step of my composer installation.
It look that when i Pause the Background Tasks, the whole terminal process stops.
Can you please provide a solution to avoid Indexing on my whole project ?

0

Hi there,

Do you install Composer packages by using the built-in IDE Composer support feature, right?

0

I'm having the same problem since I updated to 2022.1.2: "Updating indexes" starts and get stuck after a while, and didn't avance for hours.

There's not much in the logs, a few lines like this one:

INFO - #c.i.o.a.i.PopupMenuPreloader - 7227 ms since showing to preload popup menu '' at 'StructureViewPopup' in 8 ms

 

I tried to purge the cache, same behavior. I'm using Ubuntu, it's the same project I was working on before the update.

0

A similarly-sounding problem was fixed recently. It would be great if you could check out this IDE build: https://youtrack.jetbrains.com/issue/WI-66681/202211-stuck-on-Updating-Indexes#focus=Comments-27-6153461.0-0

0

2022.3 and the problem still exists.

I see this has been an issue for years.

0

There is no single unresolved major loop indexing issue and most cases are unique.
Do you experience a non-stop indexing? Could you please tell us more about it?

0

I also struggle with endless indexing loops I have some legacy code with big single files where I excluded any analysis this helps a bit.

0
 
Tobias Watzka, we have some known issues with indexes being reset unexpectedly in 2022.3, but they are supposed to be fixed in 2023.1.
Could you please check how it goes there for you? https://www.jetbrains.com/phpstorm/nextversion/
 
Please note that after major upgrades, it's expected to have all projects fully re-indexed, but after that, it should be good. If it's not, please share your logs (Help | Collect Logs and Diagnostic Data) in a support ticket (Help | Contact Support). Thank you!
0

I'm having this issue as well this week, I'll try out the 2023.2 EAP. It would be nice to abort the indexing easily, though.

0

Try to delete the system directory https://www.jetbrains.com/help/phpstorm/directories-used-by-the-ide-to-store-settings-caches-plugins-and-logs.html#system-directory when the IDE is not running. — Serge Baranov 

This fixed it for me, thanks Serge!

4

I had this very same issue today with 2023.1.4 and it was solved by removing the system directory in ~/Library/Caches/JetBrains/ as per the above post. 

1

Hi, i'm having the same problem. Any solution in definitive?

0

Without the logs, we won't be able to tell what is going on.
Please submit your logs (Help | Collect Logs and Diagnostic Data) in a support ticket (Help | Contact Support), we'll have a look. Thanks!

0

Claudio, the fix above mentioned in https://intellij-support.jetbrains.com/hc/en-us/community/posts/360010115960/comments/11667067608978 fixed for me, but as Eugene mentions there could be other reasons

0

I'm having the same problem since I updated to 2023.3. The last steps don't work for me

0

Hi,

Do you have a Symfony plugin by the chance?

0

Yes, I have plugin “Symfony support”

2

I resolved the problem when I updated plugin. thank you! 

1

Fantastic, thank you for the confirmation!

0

I had the same issue and updating the plugins solved it. (I have the Symfony one, too.)

Thanks for the hint.

 

0

Confirming that updating Symfony plugin helps resolving the issue. Thanks!

0

I have the same issue in IntellIJ IDEA. But It is just in one project. 

I fixed with https://intellij-support.jetbrains.com/hc/en-us/community/posts/360010115960/comments/12650555298194 comment. I closed IDE and then I removed IntelliJIdea* directories.  

It works! Thank you Kayleigh Whitehurst!

0

请先登录再写评论。