Can't write double quotes in Pycharm and Idea

已回答

I am using 2018 Macbook Pro Big Sur. I can't type " in Pycharm and Intellij Idea. By default I use control + option + i    shortcut to write " but it won't work on IntelliJ. I am tired of copying and pasting " into my code each time. I suspect this has something related to the shortcuts. Is there a solution to this? Thanks.

1

Hi,

What keyboard layout do you use?
Is this shortcut assigned to any action in IDE? (use Find Actions by Shortcut button in keymap settings to check)

0

Thanks for your reply. The only shortcut assigned to the same keys was the auto-indent lines shortcut (control + option  + i ) which I had already replaced. I use Turkish Q keyboard layout in my mac. However, my physical keyboard is US keyboard so I can't use the " button to type ". 

0

buy a turkish keyboard 

 

 

( joke)

0

It could be, but It's on Linux and I can type '. I just have problems with " and I am on mac. When I switch my keyboard to US on mac preferences I am able to type " - it just doesn't work with the Turkish keyboard.

0

Could you please share idea.log ("Help | Show Log in...") after restarting IDE?

0

Is it reproducible with custom plugins disabled:

 Loaded custom plugins: One Dark theme (5.1.4), Tabnine AI Autocomplete: JavaScript C Python Ruby Rust Go PHP... (0.3.2), EduTools (2021.2-2020.3-840) 
0

I disabled all of them but I still have the issue.

0

Did you solve this issue? Because I have a same problem, I am using Turkish Q keyboard but my physical keyboard is US. I cant do double quotes.

1

No, unfortunately I couldn’t. I got used to using single quotes or copying-pasting “ from the internet. Although if you want to type “ somewhere other than jetbrains ide’s you can use control+option+i on mac.

Edit: See the update below

0

control + i work perfect on mac but not work in jetbrains. it is problem for ide. i look not see shortcut key for control + i but still not working. 

0

Update: I added a macro shortcut to control + option + i which types “. Works perfectly without any issues.

0

Thanks for the feedback. i used karabiner app for Mac 

0

I was having the same problem on the most recent version of PyCharm 2022.1 (Professional edition)  on Ubuntu 20.04
I have a  US keyboard

My keyboard layout on Ubuntu is US international with dead-keys (in other languages shows as "US internatila with accent keys")
This means that  in most applictions I type two keystrokes such as:  [ " ] then [ o ] to produce ö   or [ ' ] then [ e ]  to produce é. However the first keystroke doesn't normally produce the double-quotes / quote unless I press [ SPACE ]  right afterwards. 

This is how it works in most applications, but NO SO on Pycharm. For somereason Pycharm is the only app that gets confused. 

Ubuntu has an option to show the keyboard layout graphically an there I discovered the way to actually type "  or  ' on Pycharm!: 

Alt Gr +  '  (single-quote) => Types ' (single-quote)

Alt Gr + Shift +  '  => Types " (double-quote)

Alt Gr + ` => Types ` (inverted quote) 

Maybe this works on Turkish with accented keys layouts as well... 

 

0

I was having the same problem but in Goland. I know this is a old thread, but for me it works using the "US, altgr with dead keys"  layout on PopOS with gnome.

 

0

Had the same issue in manjaro linux rebooting did "fix" it.

0

System Settings -> Keyboard -> Input Sources ->  Disable "Use smart quotes and dashes". Then you can use the key one below esc as double quotes.

0

请先登录再写评论。