Clion can not open in my Mac


The app just not opening , I click it and nothing happen, the app not even show up in the force quit window, I restart the computer still not opening in any ways the app just can not open and there is no any kinds of notification and massage that tells me why it can not open. but no matter how I click the app it just not open, I delete it and download again, still not opening , I use the earliest Big Sur OS system 


The user has contacted us via the support system, but hasn't provided the requested information.

Xhong5 is the issue still relevant for you?


I had the same issue. I launched clion from terminal, `/Applications/` and saw that error was a wrong value in custom vm options. So, changing `$HOME/Library/Application\ Support/JetBrains/CLion2021.1/clion.vmoptions` helped me


Hello, (Aleksandr Gruzintsev)

I have run into the exact same error as you, however I was wondering how you changed `$HOME/Library/Application\ Support/JetBrains/CLion2021.1/clion.vmoptions`, as I do not have a ‘JetBrains’ folder in ‘Application Support’?

Thank you very much.


Hi Nishaddeokar,

Could you try to launch the app via terminal? That time I figured out that the problem is about clion.vmoptions because there had been some helpful messages in standard output. Maybe there would be another hint for your case


Dear Aleksandr Gruzintsev,

My problem was also about clion.vmoptions, but I just couldn't locate the file on my computer. I eventually figured out that the file was in fact hidden for me and so after pressing 'Command' + 'Shift' + '.' I found the file and hence solved the issue. Thank you very much for your help :)


I have the same problem with CLion. I had this problem with Pycharm as well. Not sure what the underlying cause is. Need help soon.

I'm on the latest MacOS


Chapm361 please try running CLion from the Terminal:

cd /Applications

And provide the console output.


You probably installed Apple Silicon even though you have intel cpu.

Try downloading toolbox with MacOS Intel and then download  Clion.