Need help filing issues about massive problems with symbols in IU-2021.1



I am seeing massive problems with symbols in IDEA Ultimate 2021.1 that weren't there in 2020.3 and need help on how to narrow it down. Here is what I am seeing:

  1. Classes are shown as unused in the editor. Find usages does not find the usages even though there are hundreds. This seems like an indexing issue because it can be resolved by Invalidate Caches
  2. Symbols are shown in red because they are not found. This can be classes that are referenced by other classes. It seems to be related to moving classes between source roots of modules which seems to forget to update some internal data structures . When it happens, the code compiles and it can be fixed with closing and reopening the project.

The problem is, it does not happen every time which makes it very difficult to gather the necessary information to file a bug in YouTrack. From what I haven't seen, idea.log isn't really helpful when it happens. I know that quite a few issues related to indexing have been fixed in EAP but it seems like there are still some serious problems that have not been addressed. Is there any additional logging that could be helpful to track this down?

This basically makes it almost impossible to use 2021.1 on any serious refactoring project. Any help narrow this down to file issues is greatly appreciated. I have been using IntelliJ IDEA EAP and stable version since 2.6. The 2021.1 release is the first stable release where I am considering to go back to a previous release.


Generally, cache invalidations should help (with selecting "Clear file system cache"). 

You may also remove/rename .idea directory in the project's root and re-import the project.

The fix for these situations will be available in 2021.1.1 soon


Thanks for the update! I'd be happy to help find any corner cases that might not be covered yet.


Thank you for your proactivity. 

EAP version of 2021.1.1 with all the cache-related fixes will be available for download within the next week. You can download it at

If some of the issues are still not fixed, please submit a new ticket at with idea.log attached. 

Thank you. 


I am still seeing these problems with IU-211.7142.36. I have just moved classes between source roots. The resulting code compiles without any errors but IDEA shows weird things in the editor:

Some member variables are underlined in red in constructors. The reason is "Cannot access de.some.package.SomeClass". The offending type is located in the same directory/package as the class that shows the error. 

In addition to that I am seeing errors in another module:

Some variable definitions and method calls are also shown in red (cannot resolve method). 

The setup is something like this:


Classes were moved to from Module_Source to Module_Dest (but stayed in the same package). Classes in Module_Third show the errors mentioned above but everything compiles fine. I have verified that Module_Third depends on both Module_Source and Module_Dest (otherwise it would not compile).

There is still something massively broken with Refactor > Move. I am also still seeing but still found no way to find steps to reproduce. The log file does not show anything related to the problem.


This is another issue and I cannot reproduce it, sorry. 

Once you find a way, please make a not at YouTrack about it. 

We are also working continuously to improve caches consistency.


Here is another clue for this problem: in some instances IDEA shows the dialog "File Cache Conflict - Changes have been made to <file> in memory and on disk." That dialog is shown for a large number of files (sorry, these moves are quite big and it's hard to keep track if that dialog really appears for every single file). When you click on show differences, you see the old imports on one side and the new ones on the other side. Maybe it's not something directly in the Refactor > Move code path but with the machinery that is also involved (like file system refresh, Git integration, …)? Just wild guesses here.

There are no simple steps to reproduce that and I am not seeing anything helpful in idea.log so far. Believe me, I have tried hard. Is there some kind debug logging I can turn on?