How to adopt my idea plugin for multi-versions?

How can I adapt my plugin? The following is my configuration. When I run the'runPluginVerifier' task, the following error message will appear. May I ask, how can I solve this problem?

  My plugin.xml configuration like the following.

 

2021-05-05T21:34:05 [main] INFO verification - Finished 1 of 3 verifications (in 7.1 s): IU-202.8194.7 against com.senjoeson.plugin:1.4: 2 compatibility problems
2021-05-05T21:34:06 [main] INFO verification - Finished 2 of 3 verifications (in 8.0 s): IU-203.8084.24 against com.senjoeson.plugin:1.4: 2 compatibility problems
2021-05-05T21:34:06 [main] INFO verification - Finished 3 of 3 verifications (in 8.2 s): IU-211.7142.45 against com.senjoeson.plugin:1.4: Compatible
Plugin com.senjoeson.plugin:1.4 against IU-202.8194.7: 2 compatibility problems
Compatibility problems (2):
#Access to unresolved class com.android.tools.idea.res.IdeResourcesUtil
Method com.senjoeson.plugin.hook.AndroidAddStringResourceAction.doInvoke(Project project, Editor editor, PsiFile file, String resName, PsiElement element, ResourceType type) : void references an unresolved class com.android.tools.idea.res.IdeResourcesUtil. This can lead to **NoSuchClassError** exception at runtime.
Method com.senjoeson.plugin.hook.AndroidAddStringResourceAction.createJavaResourceReference(Module module, Editor editor, PsiFile file, PsiElement element, String aPackage, String resName, ResourceType resType) : void references an unresolved class com.android.tools.idea.res.IdeResourcesUtil. This can lead to **NoSuchClassError** exception at runtime.
Plugin can be loaded/unloaded without IDE restart

Plugin com.senjoeson.plugin:1.4 against IU-203.8084.24: 2 compatibility problems
Compatibility problems (2):
#Access to unresolved class com.android.tools.idea.res.IdeResourcesUtil
Method com.senjoeson.plugin.hook.AndroidAddStringResourceAction.doInvoke(Project project, Editor editor, PsiFile file, String resName, PsiElement element, ResourceType type) : void references an unresolved class com.android.tools.idea.res.IdeResourcesUtil. This can lead to **NoSuchClassError** exception at runtime.
Method com.senjoeson.plugin.hook.AndroidAddStringResourceAction.createJavaResourceReference(Module module, Editor editor, PsiFile file, PsiElement element, String aPackage, String resName, ResourceType resType) : void references an unresolved class com.android.tools.idea.res.IdeResourcesUtil. This can lead to **NoSuchClassError** exception at runtime.
Plugin can be loaded/unloaded without IDE restart

Plugin com.senjoeson.plugin:1.4 against IU-211.7142.45: Compatible
Plugin can be loaded/unloaded without IDE restart

2021-05-05T21:34:06 [main] INFO verification - Total time spent downloading plugins and their dependencies: 0 ms
2021-05-05T21:34:06 [main] INFO verification - Total amount of plugins and dependencies downloaded: 0 B
2021-05-05T21:34:06 [main] INFO verification - Total amount of space used for plugins and dependencies: 6.22 MB

请先登录再写评论。