Cannot upgrade kotlin plugin

I get an "update kotlin plugin" popup from time to time, like this:

A new version 211-1.5.10-release-891-IJ7142.45 of the Kotlin plugin is available.

but whenever I try to install it I get a message:

Downloaded version (1.3.72-release-IJ2020.1-5) is older than the currently installed version (211-1.5.0-release-759-IJ6693.72).

So how to update it?

IntelliJ IDEA 2021.1.1 (Ultimate Edition)
Build #IU-211.7142.45, built on April 30, 2021
Subscription is active until July 17, 2021.
Runtime version: 11.0.10+9-b1341.41 amd64
VM: Dynamic Code Evolution 64-Bit Server VM by JetBrains s.r.o.
Linux 5.8.0-53-generic
GC: ParNew, ConcurrentMarkSweep
Memory: 9981M
Cores: 8
Non-Bundled Plugins: Base64 for IDEA and Storm (1.1b), Batch Scripts Support (1.0.12), CMD Support (1.0.5), Dilbert (1.9.0.168), IdeaVIM (0.67), Statistic (4.1.7), com.alayouni.ansiHighlight (1.2.4), com.github.leomillon.uuidgenerator (4.4.0), com.intellij.apacheConfig (211.6693.108), com.intellij.ideolog (203.0.27.0), com.jetbrains.plugins.ini4idea (211.6693.44), com.intellij.plugins.watcher (211.6693.44), com.khmelyuk.multirun (1.11.2), com.sburlyaev.terminal.plugin (0.4.4), de.ax.powermode (100.001), detekt (1.17.1), main.kotlin.com.jimschubert.intellij.swaggercodegen (4.3.1-p0), nl.jworks.intellij.bootstrap3 (4.1.1), org.github.plugin.redis-simple (1.1.4), org.intellij.plugins.hcl (0.7.10), com.crunch42.openapi (1.15), org.sylfra.idea.plugins.linessorter (1.0.1), org.turbanov.run.configuration.as.action (1.4.4), send2terminal (1.4.1), GrepConsole (11.9.211.6086.0), SpotProfiler (2.0), com.euphoricity.gitignore (0.3), com.github.syuchan1005.ImageComment (1.0.2), com.intellij.bigdecimal-folding (0.9.9.8.6), com.linsage (1.0.6), de.u-mass.idea.copyConstructor (1.2), marcglasberg.HibernateInspectionsPlugin (1.1), org.sonarlint.idea (4.16.0.31683), com.deadlock.scsyntax (211.6693.111), com.ifengxue.plugin.jpa-support (2.0.7-RC3), org.jetbrains.kotlin (211-1.5.0-release-759-IJ6693.72), com.bruce.intellijplugin.generatesetter (2.7), com.suusan2go.kotlin-fill-class (1.0.7), org.mapstruct.intellij (1.2.4), com.intellij.plugins.html.instantEditing (211.6693.111), org.jetbrains.plugins.ruby (211.7142.36), PlantUML integration (5.3.0), Pythonid (211.7142.45), net.ashald.envfile (3.2.1), ru.adelf.idea.dotenv (2021.1), nl.rubensten.texifyidea (0.7.6)
Kotlin: 211-1.5.0-release-759-IJ6693.72
Current Desktop: ubuntu:GNOME

Related log file:


2021-06-01 09:20:56,782 [327379998] INFO - er.VisualOperatorActionHandler - Execute visual command Command(rawCount=0, action=com.maddyhome.idea.vim.action.change.change.ChangeVisualAction@4d5272dc, type=CHANGE, flags=[FLAG_EXIT_VISUAL, FLAG_MULTIKEY_UNDO])
2021-06-01 09:21:02,331 [327385547] INFO - rketplacePluginDownloadService - Unable to download plugin via blockmap
com.intellij.util.io.HttpRequests$HttpStatusException: Request failed with status code 404. Status=404, Url=https://plugins.jetbrains.com/files/6954/89208/kotlin-plugin-1.3.72-release-IJ2020.1-5.zip.blockmap.zip
at com.intellij.util.io.HttpRequests.throwHttpStatusError(HttpRequests.java:668)
at com.intellij.util.io.HttpRequests.openConnection(HttpRequests.java:639)
at com.intellij.util.io.HttpRequests$RequestImpl.getConnection(HttpRequests.java:356)
at com.intellij.util.io.HttpRequests$RequestImpl.getInputStream(HttpRequests.java:364)
at com.intellij.ide.plugins.marketplace.MarketplacePluginDownloadService$downloadPluginViaBlockMap$newBlockMap$1.process(MarketplacePluginDownloadService.kt:69)
at com.intellij.ide.plugins.marketplace.MarketplacePluginDownloadService$downloadPluginViaBlockMap$newBlockMap$1.process(MarketplacePluginDownloadService.kt:23)
at com.intellij.util.io.HttpRequests.doProcess(HttpRequests.java:531)
at com.intellij.util.io.HttpRequests.process(HttpRequests.java:513)
at com.intellij.util.io.HttpRequests$RequestBuilderImpl.connect(HttpRequests.java:332)
at com.intellij.ide.plugins.marketplace.MarketplacePluginDownloadService.downloadPluginViaBlockMap(MarketplacePluginDownloadService.kt:68)
at com.intellij.ide.plugins.marketplace.MarketplaceRequests.downloadPluginViaBlockMap(MarketplaceRequests.kt:384)
at com.intellij.openapi.updateSettings.impl.PluginDownloader.downloadPlugin(PluginDownloader.java:311)
at com.intellij.openapi.updateSettings.impl.PluginDownloader.prepareToInstallAndLoadDescriptor(PluginDownloader.java:176)
at com.intellij.openapi.updateSettings.impl.PluginDownloader.prepareToInstallAndLoadDescriptor(PluginDownloader.java:144)
at com.intellij.openapi.updateSettings.impl.PluginDownloader.prepareToInstall(PluginDownloader.java:140)
at org.jetbrains.kotlin.idea.KotlinPluginUpdater$installPluginUpdate$4.run(KotlinPluginUpdater.kt:276)
at com.intellij.openapi.progress.impl.CoreProgressManager$TaskRunnable.run(CoreProgressManager.java:998)
at com.intellij.openapi.progress.impl.CoreProgressManager.lambda$runProcessWithProgressAsync$5(CoreProgressManager.java:497)
at com.intellij.openapi.progress.impl.ProgressRunner.lambda$submit$3(ProgressRunner.java:228)
at com.intellij.openapi.progress.impl.CoreProgressManager.lambda$runProcess$2(CoreProgressManager.java:178)
at com.intellij.openapi.progress.impl.CoreProgressManager.registerIndicatorAndRun(CoreProgressManager.java:688)
at com.intellij.openapi.progress.impl.CoreProgressManager.executeProcessUnderProgress(CoreProgressManager.java:634)
at com.intellij.openapi.progress.impl.ProgressManagerImpl.executeProcessUnderProgress(ProgressManagerImpl.java:64)
at com.intellij.openapi.progress.impl.CoreProgressManager.runProcess(CoreProgressManager.java:165)
at com.intellij.openapi.progress.impl.ProgressRunner.lambda$submit$4(ProgressRunner.java:228)
at java.base/java.util.concurrent.CompletableFuture$AsyncSupply.run(CompletableFuture.java:1700)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
at java.base/java.util.concurrent.Executors$PrivilegedThreadFactory$1$1.run(Executors.java:668)
at java.base/java.util.concurrent.Executors$PrivilegedThreadFactory$1$1.run(Executors.java:665)
at java.base/java.security.AccessController.doPrivileged(Native Method)
at java.base/java.util.concurrent.Executors$PrivilegedThreadFactory$1.run(Executors.java:665)
at java.base/java.lang.Thread.run(Thread.java:834)
2021-06-01 09:21:06,631 [327389847] INFO - Settings.impl.PluginDownloader - Plugin org.jetbrains.kotlin: current version (max) 1.3.72-release-IJ2020.1-5
2021-06-01 09:21:06,631 [327389847] INFO - Settings.impl.PluginDownloader - PluginDownloader error: Downloaded version (1.3.72-release-IJ2020.1-5) is older than the currently installed version (211-1.5.0-release-759-IJ6693.72).
评论操作 固定链接

I still get that message

Popup:

11:09 Kotlin: A new version 211-1.5.10-release-909-IJ7142.45 of the Kotlin plugin is available. Install

Error message

Plugin "Kotlin" was not installed: Downloaded version (1.3.72-release-IJ2020.1-5) is older than the currently installed version (211-1.5.10-release-891-IJ7142.45).

Note that it says that "A new version 211-1.5.10-release-909-IJ7142.45 is available and then Downloaded version (1.3.72-release-IJ2020.1-5) ...

0
评论操作 固定链接

However in the Settings → Plugins the version information says

211-1.5.10-release-891-IJ7142.45 → 211-1.5.10-release-909-IJ7142.45

and after clicking "update" it says the version is

211-1.5.10-release-909-IJ7142.45

0
评论操作 固定链接

Same problem on my machines. Seems that I have to work with Kotlin 1.5.10 for the time being and coming, because all newer plugins are older and will not be installed.

Really confusing.

0
评论操作 固定链接

And again the Kotlin plugin 1.5.31 cannot be installed because my old 1.3.xxx is newer (!?!?!) than anything that will come in the future. Will I ever get a new Kotlin version again? I doubt.

0
评论操作 固定链接

Same here. However when I closed all projects and disabled Kotlin plugin in the "Welcome" window, then it updated to 1.5.31. Then I re-enabled it and it stays on 1.5.31.

2
评论操作 固定链接

Thank you, Lutosław, very much. This worked for me. Tried on one of my machines and it was successful.

Closed all projects. Disabled the Kotlin plugin on the Welcome-page. Then updated the plugin and enabled it again (with obligatory restarts after each change).

Nice ;-)

0
评论操作 固定链接

I'm stuck again in this problem. After upgrade of IntelliJ to 2021.3, the bundled Kotlin plugin 1.5.30 is back and I'm not able to update it to 1.6.0 . Seem's it'll take a serious time span to solve this ...

0
评论操作 固定链接

+1 to this thread.  This has been a concern for me since beta & RC versions of Kotlin 1.6, and is still a problem.  I'll use IntelliJ as the editor, and cross-check any complaints by building on the command line (Maven or Gradle).  It slows down my coding flow.

0
评论操作 固定链接

I'm also facing this issue, stuck on Kotlin 1.5.10, check for updates doesn't prompt for any changes. And I don't see any possible "update" button on the Kotlin plugin itself. 

0
评论操作 固定链接

+1 
I uninstall IDEA, removed all files from my mac, all caches, Install lastest 2021.3 version. AND still have kotlin plugin 1.5.10.
Some time a get suggestion to update plugin to 1.6.0, but after that I receive Error.
Can't update plugin at least for 1 year

P.S. Fixed for me 👍🏻(25 Dec 2021)

 
0
评论操作 固定链接

This hit me hard today...

I tried workaround suggested by Lutosław, but with no luck.

What information we need to provide to solve this issue? 

0
评论操作 固定链接

Interestingly, the last stable versions of the Kotlin plugin seem to be incompatible with IntelliJ IDEA 2021.3. It seems to me like the root cause for this problem.

Update: There is now an RC version compatible with IDEA 2021.3: https://plugins.jetbrains.com/plugin/6954-kotlin/versions/staging

2
评论操作 固定链接

This is fixed for me -- should have posted earlier -- in 2021.3.1 Preview version of IntelliJ.

2
评论操作 固定链接

It's also fixed for IDEA version 2021.3 by now as the Kotlin 1.6.10 plugin has been released with IDEA version 2021.3.x compatibility.

3

请先登录再写评论。