Library has Kotlin runtime bundled into it


I'm building my plugin with the latest EAP snapshot (212.4321.30) to test it and see if my plugin needs updating to support that snapshot. I'm seeing the following warning:

> Task :src:lang-xpath:compileKotlin
w: Some JAR files in the classpath have the Kotlin Runtime library bundled into them. This may cause difficult to debug problems if there's a different version of the Kotlin Runtime library in the classpath. Consider removing these libraries from the classpath

w: C:\Users\user\.gradle\caches\modules-2\files-2.1\com.jetbrains.intellij.idea\ideaIC\LATEST-EAP-SNAPSHOT\c3d2c178db6afb48648905fade8d760ff3f9ab9a\ideaIC-LATEST-EAP-SNAPSHOT\lib\3rd-party.jar: Library has Kotlin runtime bundled into it

My gradle file is at

Do you know how to fix this warning?

I've tried adding:


to my file and (at the same time) commenting out the:

compile "org.jetbrains.kotlin:$kotlin_stdlib:$kotlin_version"

but I still get that warning.

Setting ext.kotlin_version to "1.5.10" (to match the intellij kotlin version), I also get:

w: Runtime JAR files in the classpath have the version 1.4, which is older than the API version 1.5. Consider using the runtime of version 1.5, or pass '-api-version 1.4' explicitly to restrict the available APIs to the runtime of version 1.4. You can also pass '-language-version 1.4' instead, which will restrict not only the APIs to the specified version, but also the language features

w: C:\Users\user\.gradle\caches\modules-2\files-2.1\com.jetbrains.intellij.idea\ideaIC\LATEST-EAP-SNAPSHOT\c3d2c178db6afb48648905fade8d760ff3f9ab9a\ideaIC-LATEST-EAP-SNAPSHOT\lib\kotlin-reflect-1.4.32-release-380.jar: Runtime JAR file has version 1.4 which is older than required for API version 1.5