PHPStorm 2021.2 stupidly slow and constantly indexing files (actually, incrementally worse ever since 2020.2^ onwards)


I have found a ticket that has since been closed, somebody complaining about 2020.3 being slow:

This is exactly my same issue and this has NOT been resolved, in fact it just became worse with each version apparently. Ever since 2020.2, every time I open up the software (on Debian by the way), it takes a lot of time.

1. On 2020.2 it would index every few weeks / months or so. Which is very acceptable.

2. On 2020.3, it was the first version (in my experience) where it started indexing every time I opened up the sofware, taking 1m-2m or so on my various projects.
I used to snap revert my package because of it, but snap package manager cannot be configured to NOT update packages (what a stupidly annoying decision but this is another story), so every few days I would see my PHSTtorm back up to 2020.3.
So, I just caved in because of snap pm, and just let my PHPStorm software get updated quarterly, because I deemed that should be the case, anyway, ultimately.

3. FINALLY, on 2021.2.2, I am as of now at 2021.2.2 and the indexing has become SO SLOW and problematic that it now takes 5m EACH TIME I open up the software.

My system is by no means slow either, this should be clear.
My configuration does not even matter, because the simple fact of the matter is this:
- 2020.2 was fast;
- 2020.3 started indexing every time, it was... somewhat acceptable;
- and by 2021.2 however, indexing is extremely slow and CONSTANT, nigh on impossible to work with.

Have to switch project? Wait 5minutes.
Have to free up resources for something else? Wait 5minutes reopening it.
Have to work with 2 (or god forbid, 3 or 4 microservices) at once? Wait 5m, 5m, 5m.
Have to restart system?
Well, it's at a point where I dread doing either, now it's at the point where it's in the back of my head: "&*^&, I have to restart PHPStorm".

Willing to bet this:
99% of your users would rather choose a reliable, fast, software in place of one that has 500 extra bells and whistles since 2020.2 onwards, making it nigh on impossible to work with.

The bells and whistles (let's look at one example: remote coding, CodeTogether or CodeWithMe or whatever you call it) is realistically used by a small % of users and can be worked without anyway, we had perfectly fine solutions and workarounds.

But making it THIS slow in favour of adding such bells and whistles ?

What going on, Jetbrains? Please make PHPStorm reliable like 2020.2 was.

I am left with either the option to do a standalone installation of 2020.2 (not snap !), or move to Visual Studio or something


Also I can see that it's indexing the excluded "myproject/vendor/*" dir every time it starts up.

And then it does another run:

I tried to invalidate caches and restart (restart multiple times *after* the cache invalidation) and it still does this. 
I tried excluding the dir, cancelling exclusion, excluding again.

It still indexes for ~5m Every. Single. Time. it starts up. 

Come on... 


 Could you please run Help > Collect Logs and Diagnostic Data and share the resulting archive somehow? 

You can upload it at or send it us directly over Help | Contact Support.


Thanks for replying.

You joke and I made a statement that is perhaps too absolute, I agree. 
Fact still remains: bells and whistles for a minority of users affects the *vast majority* of users who don't need it. There.

Also, not sure that you are in the best position to attest JB product snappiness - a JB employee (basing this on the "JB" logo in your picture).
But especially not when you can find time and time again people on various forums saying how JB / IntelliJ "are great, but if only they fixed their products speed". Let's not quite kid ourselves into ignorance here.

Will look into providing logs one of these following days.


Thanks for the reply. We use our own products daily for several years: PhpStorm, IntelliJ IDEA. We commit code, inspect others projects, test environments integrations: we do all kind of stuff so we know when something is slower than usual and when not.

I personally don't think that the latest IDE version slower than 2020.3. There are a couple of issues that could cause this impression like or so let's check the logs first.


Hi everyone,

I am suffering exactly the same issue.

Please, let me know if you need some information


Please describe what exactly is slow. Any information is appreciated.


Where can I upload the logs? I'd rather not put them here publicly.
But, the short version is this:

scanning project 13.2s
indexing project 203.5s
indexing project 0.37s
indexing project 26.76s
(One question would be: Why is it indexing 3 times?)

Total: 243.83s or 4.06 minutes

Also seeing quite a few logs saying "sluggish" AND using all 4 threads of my i7 gen 8, taking CPU to 60-70%.
I can't tell from the logs whether the "/vendor" dir was excluded from scanning and indexing - but the progress bar visible during the index tells me the directory wasn't - even though I've excluded it, restarted, reincluded, reexcluded, restarted, as I was saying in my previous message. Actually, even visible in the photos I previously attached, the ones showing the progress bar, both photos show PHPStorm is working on indexing "myproject/vendor/*'.


You can upload the logs at or send them it us directly over Help | Contact Support.


My upload was successful. Upload id: 2021_09_23_Uh8c5QXcCHqpLTc5

Two things: 
1. We've been discussing indexing / excluding "/vendor"
2. We've been discussing general sluggishness of PHPStorm on startup. 

While point 1 needs to be clarified, point 2 is the much more important one, let's not forget that.



Could you please re-upload the logs archive instead? It contains indexing performance metrics as well. You've uploaded a log file for a single IDE startup, which might not be sufficient to analyze the whole picture.

Based on the log I can tell:

1) try to download & install the IDE using our standalone installer: I can see there's ~15 seconds pause/delay on an IDE startup. These delays could happen when IDE fails to access some of the OS libraries, this could happen when IDE is installed using 3rd party app managers like snap. You can keep both IDE installations for a test.

2) there was a re-indexing event triggered by an incorrect IDE shutdown. Was IDE shut down forcibly? Or did you by any chance initiated OS shutdown/reboot while IDE was running? This is a typical reason for a complete project re-indexing. Of course, IDE would feel sluggish when it's doing a full reindexing. So please check if this happens if you gracefully exit IDE. Or check if this happens on a simple IDE restart.


My PhpStorm IDE (2021.3.1) also behaves exactly as described by OP since mid-2020 and it is getting worse with every version. My colleagues are also experiencing this. Constant indexing (including excluded directories, freezes only remediable by killing the IDE in task manager, etc.) - and the Toolbox won't even let me go back to 2020.2... Not good. I always loved JetBrains IDEs but recently I find myself using VS Code more and more because of this. The apparent cluelessness as to what can cause this is astonishing.

Apart from that, it's just gotten really slow. File icons popping in one at a time over 5 or so seconds, indentation in the file tree also "loading in" later... I've never had that before 2020.3

Please, please do something about this. I'm paying good money every year for all products pack and can barely use the software anymore in its current state.

Is there a quick way to uninstall all third party plugins / reset the entire IDE to factory defaults (not just config) to see if this helps anything?



For example, I just opened a Vue.js app (small to medium size) and did an npm run build. Then I wanted to search through the generated JS files for the spread operator (...) to see whether all occurences had been replaced by babel preset env. Freeze.

Been waiting for almost a half hour now, still stuck. UI completely unresponsive, indexing not progressing, but not even triggering the Windows alert that the app isn't responding.

I thought it might be caused by WSL, but since OP is running on Ubuntu this doesn't seem to be the case after all.


So, uninstalling all 3rd-party plugins also didn't solve anything. It's stuck indexing now for since I posted last:

Also, node_modules is marked as excluded, so why is it doing that and why does it take for ever?

I also dumped diagnostics data for you, hopefully that helps somewhat.

Upload id: 2022_01_12_QU9FkNUkSxMaCy3Y (file:


Update: Now I've completely removed all 3rd-Party plugins, then completely uninstalled all JetBrains IDEs (from Toolbox), deleted all IDE config files and directories in %appdata%, re-installed PhpStorm 2021.3.1 and opened the same project again: Stuck again indexing (some jar file now):

The file exists by the way. I've checked.

Complete waste of time, and now I also have to completely reconfigure my IDE(s) and search for my plugins again... Good job.


@Armin Linzbauer

I thought it might be caused by WSL,

Please check workarounds in

It is marked as fixed. The EAP build should be available later this week (so you can try it if you wish).


...and now I also have to completely reconfigure my IDE(s) and search for my plugins again...

Making a backup (or just renaming a folder) would be a better solution IMO. Even using standard "File | Manage IDE Settings | Restore Default Settings..." action (it makes backup before resetting them).

P.S. In recent versions they have added "File | Repaid IDE..." that helps resolving some of the IDE issues (have not used it myself yet though -- had no need).



Thanks, I didn't know about the Restore Default Settings option, but I did use the Repair IDE - sadly, that didn't help either. I will check out the workaround. Thanks for the link!