Two GitHub projects, one token. One project always prompts for GitHub login.


Using 2021.2.2 I have two public GitHub projects and one token with the necessary scopes. The Password Policy and Git have been setup per the documentation, and the Version Control, GitHub account has been created with the token and set as default.

One project pushes fine without prompting.

The other project always prompts for login. Once entered it works fine.

Have scoured the web trying to figure this out with no luck.  Any guidance would be appreciated.



Hello Todd Hill

> The other project always prompts for login. Once entered it works fine.

Could you please share screenshot of that issue?
Do I understand correctly that you have "Log in to Github" dialog when you try to push to a second repository?


Correct. Two separate public GitHub projects, one token. One project does not prompt on Push, the other prompts every time.

That is the only login prompt I see - for a Push.

Do I misunderstand and separate tokens are required for each GitHub project?

The second project always shows this dialog:

It works with GitHub.  But prompts on every Push (only).  So it's just a curious frustration.

Thank you for your time !



Todd Hill
thank you for additional info.
Is there a chance that these projects resides on organization repositories?
Do you have custom URL specified under Git | Manage remotes?
Do you keep two separate projects in separate instances of IDE or they're opened in the same window?


Thanks for the reply.

 1. No, these are both public projects.

 2. Git | Manage Remotes has the single project URL for the origin.  I do not see simply Git | Manage on the main menu.  The project URL shown is: origin : 

 3. One IDE instance, opened in the same window. Meaning one credential store as shown in the screenshots.

One other minor point - these projects are old enough that I started with username/password and transitioned to using a token.

Thanks again for your time.



Thank you for additional information.

I am sorry, but what is not clear, is that you've mentioned - two projects and one token, but under "Manage remotes" you have a single URL.
So it means it's a single repository, a single project. 
It would be helpful if you could submit a support request and share more info on these two projects in ticket. 


The other project has it's GitHub origin URL in Manage Remotes. They are two separate but related GitHub projects in two directories. Nothing odd about them.

I often open one, then the other in a new window running the one instance of IntelliJ.

The other project URL is:  origin :  and it does not prompt for login.



Thank you for your reply.

Could you please submit a support request with logs attached? Regrettably, we need logs for further investigation.


Finally resolved the problem - the hard way.

  1. In Linux did an IntelliJ "Export Settings"
  2. Moved the JetBrains-related folders out of ~/.cache, ~/.config and ~/.local/share
  3. Did a scratch install of IntelliJ
  4. Imported the settings
  5. Then re-cloned the project from GitHub using the "Login with GitHub" option

It must have been some piece of odd data that was forcing me to login on every push. Now it works without prompting for a login.

In The Grand Scheme of Things doing a scratch install, although kind of scary, is relatively easy.  There may be a prescribed re-install technique but this worked well.