Ctrl + . inserts a weird letter e

已回答

I use VSCode key map in Pycharm. The most useful shortcut for me is `Ctrl + .` for imports automation.

However, suddenly, typing `Ctrl + .` is writing the letter e on my text, instead of opening context actions.

Can someone help me?

1

Does it happen only in PyCharm?

Check if Find Actions by Shortcut in File | Settings | Keymap works correctly. It should show all the actions that use the given shortcut.

0

I am sorry it took me to answer.

Yes, it happens only in pycharm.

The shortcut is properly configured. As Ctrl+. is not working properly, I also added the Alt+. for this action because I use it a lot.

0

What keyboard layout (input source) do you use?

0

Same issue using

IntelliJ IDEA 2021.2.3 (Community Edition)
Build #IC-212.5457.46, built on October 12, 2021
Runtime version: 11.0.12+7-b1504.40 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
Linux 5.13.0-21-generic
GC: ParNew, ConcurrentMarkSweep
Memory: 1921M
Cores: 8
Registry: ide.balloon.shadow.size=0
Non-Bundled Plugins: org.toml.lang (0.2.155.4114-212), some.awesome (1.14), IdeaVIM (1.8.1), mobi.hsz.idea.gitignore (4.3.0), com.mallowigi (50.2.0), com.intellij.plugins.vscodekeymap (212.3116.29), ru.artyushov (1.2.0), org.rust.lang (0.4.160.4261-212), aws.toolkit (1.35-212), com.chrisrm.idea.MaterialThemeUI (6.9.1), org.intellij.scala (2021.2.24)
Kotlin: 212-1.5.10-release-IJ5457.46
Current Desktop: Budgie:GNOME

Input source is German

1

I use and `English (US)` and `English (US , alt, international)`, switching between the two when necessary. The bug persists in both layouts. 

I also use Fedora 35 with Gnome41

0

Viniciusvargas Mrt181

Does the issue go away if you add -Dawt.ime.disabled=true to the Help | Edit custom VM options and restart the IDE?

I filed a new issue IDEA-283211 in our tracker. If the above suggestion does not help please kindly upvote, leave a comment there and share the following info:

1. The output of the set | grep -E 'XMODIFIERS|GTK_IM_MODULE|QT_IM_MODULE';setxkbmap -query

2. Your IDE Help | About info (if you have not provided it yet) and a screenshot of the Settings | Keymap page

3. Does the issue affect only Editor or other controls like text fields or Terminal also demonstrate it? Do any other shortcuts or keys produce the same 'e' character?

Thank you for your time and patience.

0

Adding this -Dawt.ime.disabled=true to `Help | Custom VM options` fixes the problem for me.

But it  adds another problem

I can no longer enter theses characters in intellij

  • `
  • ~
  • ^
  • ´
  • ¨

 

0

When using keyboard layout `English (US)`:

  • Ekaterina Valeeva sugesttion worked and didn't introduced a new issue that I could find until now.

When using `English (US, international)`:

  • I got the same behaviour as Mrt181: the previous issue is fixed but I can't time some special characters.
0

Viniciusvargas Mrt181 thanks a lot for the feedback.

Could you please try disabling the ibus-daemon and check how it's going with and without the "-Dawt.ime.disabled=true" option?

0

Faced the same issue in WebStorm 2022.1

Build #WS-221.5080.193, built on April 10, 2022

Runtime version: 11.0.14.1+1-b2043.25 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.

'Ctrl +' inserts weird 'e' instead of copied text. And it is impossible to delete this `e`.

Restarting WebStorm does not solve this issue.

0

Igor Rudakov kindly upvote the IDEA-283211 in our tracker.

As a workaround you might want to try the one from user. Alternatively, disable the ibus-daemon. Sorry for the inconvenience.

0

Ekaterina Valeeva thank you.

I have solved my problem. As I understood the issue was related to the Ubuntu more. 

This solution helped me: 

Paste in mc is failing on Gnome Terminal by adding extra characters at front and
back of the desired string. e.g. copying (highlighting) the "/.."
string from the mc list of files and directories gets pasted (middle
mouse button or Ctrl-Shift-V) as "^[[200~/..^[[201~"

http://midnight-commander.org/ticket/3207

0

Igor Rudakov thank you for sharing the solution, glad to know you succeeded to resolve the issue.

1

After spending a lot of time, restarting ide - finally found solution - press "Esc"...

3

The link from language_server_lover worked for me, thanks!

0

I recently stumbled upon this same issue, except in my IDE 'ctrl+.(period)' is responsible for folding code.

the problem lied in the system keyboard settings, the same shortcut was assigned by default to 'emoji annotation' or sth like that, changing the shortcut fixed the problem as system shortcuts override IDE shortcuts.

Thing is this problem was found on VM Kubuntu, so I suppose it might concern all Ubuntu flavours, as I haven't had that problem on RHEL distro or Arch 

0

Same problem. Ubuntu 22.04 and PhpStorm 2022.2.2. I press Ctrl + /, and E appears. And I can’t remove it right away, it freezes in the editor, then disappears. Very annoying.

0

Hi all,

There is also known issue in KDE with system emoji shortcut clashing with IDE shortcuts https://youtrack.jetbrains.com/issue/IDEA-302891/KDE-Ctrl-and-CtrlShiftU-shortcuts-do-not-work-in-Kubuntu-2204

As a workaround I've disabled system shortcuts with:

gsettings set org.freedesktop.ibus.panel.emoji hotkey "[]"
gsettings set org.freedesktop.ibus.panel.emoji unicode-hotkey "[]"
4

As a workaround I've disabled system shortcuts with:

gsettings set org.freedesktop.ibus.panel.emoji hotkey "[]"

worked for me!

2

Ubuntu 22.04 and PhpStorm the same problem on RU language

helps this.

As a workaround I've disabled system shortcuts with:

gsettings set org.freedesktop.ibus.panel.emoji hotkey "[]"
gsettings set org.freedesktop.ibus.panel.emoji unicode-hotkey "[]"
0

Very simple solution : on ubunutu, switching from current language to another and come back to the original language solved my problem

0

请先登录再写评论。