Elixir IDE


Does JetBrains team consider creating a dedicated IDE for Elixir language in foreseeable future? I'm huge fan of JetBrains IDEs, and currently I'm learning Elixir. Unfortunately, existing plugin for Elixir seems not working well/crashing, and best what I can get at the moment is VSCode with elixir plugin, which feels like huge downgrade in coding experience for me.


Jakub, there are no plans from our side to create another Elixir plugin for now. As I see, the vendor of that plugins is constantly working on it, so it doesn't seem to be abandoned. Have you tried reaching them via GitHub Issues (https://github.com/KronicDeth/intellij-elixir/issues) or submitting an exception thrown within the IDE? Looking at the implementation of Elixir, all reports also go directly to GitHub.


Jakub, I'm creator of the of Elixir plugin.  I'd need more details of what you mean by "not working well/crashing".  It's rare I get reports of full crashes from users where nothing works.

If you mean it is generating error reports often, that doesn't mean the plugin is crashing.  There are often places in the plugin that return a "safe" value like not resolving a call or not highlighting something when I haven't encountered that code value, but I still log it as an error to be reported to encourage users to open up issues with a code sample, so I can improve the heuristics the plugin uses to understand libraries like Phoenix, LiveView, and Ecto.  Please open a GitHub issue (https://github.com/KronicDeth/intellij-elixir/issues) with the error report you're getting. 

If you're not getting an error report and stuck setting up the plugin, I can help walk you through the setup on the Elixir Lang slack #intellij-elixir channelThe Elixir Lang slack can be joined if you're not already a member.  You can also PM me there directly.  My username is KronicDeth there too.

If you prefer not to use the Slack (since it loses history since it's not a paid instance) you can open a topic or DM me on ElixirForum.



I keep getting this IDE Internal Error at the bottom right of my screen when using RubyMine and activating your plugin. Is there any way I can disable this popup? I've tried disabling popups, but it seems that IDE Internal Errors will always show. I'm happy for errors to be shown in the toolbar, but it's distracting to keep getting the balloon popups when writing Elixir code.


I have to click the red dot to see those balloons, so I think that is a general setting for the IDE. I don’t use a notification ballon API. I just use the error reporting API and so whether you see them immediately or not is a general setting.


Unfortunately, Jakub Chrzanowski the support is not that great, and the plugin is largely unusable. It is a single-person operation, and therefore lacks major features, that VSCode plugins had for years now, and most of the answers on support tickets end with something along the lines of "works for me" from KronicDeth . At the end of the day, the plugin is not a great experience, and because of this, you won't see much usage of Elixir within the JetBrains ecosystem - everyone just picks either VSCode or a terminal text editor.


Any plans to adopt the Elixir plugin or at least support KronicDeth in the effort to maintain it? With the BEAM language family growing, JetBrains could treat Elixir, Erlang and Gleam devs a bit more seriously.