pycharm doesn't configure the arabic_reshaper module

已完成

I tried to configure arabic_reshaper module for education purposes in pycharm professional and it doesn't recognize it even though i have installed it with "pip install --upgrade arabic-reshaper" command taken from https://pypi.org/project/arabic-reshaper/ then tried it in terminal and it worked.
I tried a different approach by going to Settings > Project > Python interpreter > + button but nothing shows up. so what is the problem? and how can I resolve it?

Thanks in advance :)

评论操作 固定链接

Hi, I assume you're talking about this module

Make sure you have installed the package for the same interpreter that is configured as your default project interpreter. Open PyCharm terminal and run `pip list | grep arabic` - does it show anything? 

1
评论操作 固定链接

I had the message that pip is not as the same version as the project's so I had to type the following to upgrade:

/home/'username'/PycharmProjects/pythonProject/venv/bin/python -m pip install --upgrade pip

I retried to install the arabic_reshaper package through pycharm terminal with the following command:

'pip install --upgrade arabic-reshaper python-bidi pillow'


and it configured it. Thank you.

0

请先登录再写评论。