"Analyzing" never finishes

已回答

Hi all!

I'm trying out this software in an attempt to find a new IDE which I can use to increase my productivity, and I've run in to a problem with the code analysis which I'm looking for some help with. I'm currently using:

IntelliJ IDEA 2021.3.1 (Community Edition)
Build #IC-213.6461.79, built on December 28, 2021
Runtime version: 11.0.13+7-b1751.21 amd64

It's a fairly simple setup for now. I just went with all the defaults, installed the EmmyLua plugin (bundled 1.3.6.222-IDEA213), then went to work on some LUA files.

Every time I launch the IDE, I get the following Fatal Error:
`update failed for ActionGroup(com.intellij.execution.actions.RunContextAction, id=RunClass) with text=Run context configuration`

The error states that the exception is in the Android plugin, so I disable that, then the Fatal Error no longer appears, but the editor remains stuck "Analyzing...", and the "Problems" tab doesn't update.

I tried disabling the EmmyLua plugin as well, but the error still occurs. 

Manually running "inspect code" finishes stating there was nothing found to report, even when there is. 

 

Any ideas how to get the real-time code analysis working properly?

TIA :)

2

Please reproduce the problem with Android plugin disabled (and IDE restart) and share the logs folder compressed. You can use https://uploads.jetbrains.com/ for sharing. 

0

Thanks for your reply Konstantin!

I completely re-installed the IDE, and this time I installed the plugin through the IDE instead of manually.

Since re-installing, there are occasional plugin errors, but not to the point to "break" the real time analysis.

0

Code analysis does not work in PhpStorm. The phrase "Analyzing" always appears in the upper right corner.
- I tried the Repair IDE and Invalidate Caches options, but they didn't work.
- I deactivated all plugins but it was not resolved.
- I deleted PhpStorm, completely deleted it.
~/Library/Application Support/JetBrains/PhpStorm2024.1
~/Library/Caches/JetBrains/PhpStorm2024.1
I deleted the files.
I installed from scratch but it didn't work.

I had no problems using the 2023 version before. But now I'm having a hard time tracking my errors in php. It doesn't even warn me about undefined variables within the same function. This makes my job quite difficult.

I uploaded Collect Logs and Diagnogstig Data to your server

Upload id: 2024_06_08_Fva9TWZneMnH91eJzcpvM6 (file: phpstorm-logs-20240608-1141537820228295581823169.zip)

How can I solve this problem?

About PhpStorm;

PhpStorm 2024.1.2
Build #PS-241.17011.119, built on May 28, 2024
Licensed to Bilal YILMAZ
Subscription is active until July 15, 2024.
Runtime version: 17.0.11+1-b1207.24 aarch64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
macOS 14.5
GC: G1 Young Generation, G1 Old Generation
Memory: 2048M
Cores: 10
Metal Rendering is ON
Registry:
 debugger.new.tool.window.layout=true
 run.processes.with.pty=TRUE
 ide.experimental.ui=true
Non-Bundled Plugins:
 com.intellij.ideolog (222.3.2.0)
 com.markskelton.one-dark-theme (5.11.0)
 String Manipulation (9.14.1)
 com.intellij.ml.llm (241.17011.2)
 ru.adelf.idea.dotenv (2024.1)
 de.espend.idea.php.annotation (10.0.0)
 izhangzhihao.rainbow.brackets (2024.2.4-241)
 fr.adrienbrault.idea.symfony2plugin (2024.1.274)
 zielu.gittoolbox (500.2.9+233)
 mobi.hsz.idea.gitignore (4.5.3)
 

0

Please attach logs after reproducing the issue with all custom plugins disabled. Also please disable “Grazie” plugin.

0

It was fixed when I removed the Proofreading setting from the configure inspections window. I tried one by one to find this solution, it worked when I removed proofreading.

Thank you for your attention Yaroslav

2

Hi Yaroslav Bedrov… 

I'm using `pycharm 2024.1.4` .

The "Grazie" plugin + Proofreading are all disables.

 

when I open a new file, pycharm keeps analyzing (no matter how big is this file) and never ends.

 

 

Here is analyzer status:

 

Here are the most recent logs:

0

Hi zamoosh,

See if it helps to re-generate project configuration settings:

  1. Close the IDE, go to the project directory, backup and delete the entire .idea folder and any .iml files from its root
  2. In the IDE, go to File | New | Project from existing sources, select the project's source (root directory or main build file)
  3. Wait for indexing to finish

If the problem remains:

  1. Disable ALL non-bundled plugins: File | Settings | Plugins | ⚙ | Disable all downloaded plugins
  2. Initiate index rebuild manually via File | Invalidate Caches & Restart

If it doesn't help, please provide IDE logs for analysis (entire archive): Help | Collect Logs and Diagnostic Data. I will search for exceptions and check your system environment settings. File can be uploaded privately to our server at https://uploads.jetbrains.com.

1

Hi, Arina Efremova )

I have the same problem.

I tried to reindex a new project from existing sources. It didn't fix the problem. After that I tried to invalidate cashes. It also didn't help. As it's written above I also tried to uncheck Proofreading Inspection - without result.

So may I join to conversation and send you my IDE logs?

0

Hi Zoodov - of course, feel free to upload them to https://uploads.jetbrains.com and provide the id of the upload here.

0

Arina Efremova, thank you)

Upload id: 2024_07_15_7UuVznQpchQoHGCxWnciqs

0

Thanks Zoodov

I found the relevant exception and reported the issue to YouTrack so that our PHP developers can take a look: https://youtrack.jetbrains.com/issue/WI-78268

You can follow the progress and leave additional comments there. 

As a workaround in the meantime, you can try version 2024.2: https://www.jetbrains.com/phpstorm/nextversion

0

请先登录再写评论。