Mac users - High cpu and heating up when I open IntelliJ


When I open IntelliJ Ultimate and do nothing (dont open any project) just open but temperature reaches 80 degrees Celius and fans run at full speed. I do dissable all plugin but there is no change . It's weird. The temp of my Macbook is normally between 45-50 degrees. 
I use MBP 15 2019 i7 16G 258. Do you have any advice or setting for this issue ? 


What is the version of IntelliJ IDEA? What about other apps like Chrome? 

High CPU usage can be caused by throttling after temperature increases. You can monitor throttling via the Hot application. Better cooling (fans cleaning or thermo paste replacing) helps in case the OS limits CPU maximum. 



I downloaded the newest on download website. Other apps Xcode, okay but IntelliJ is not. However, it works normally now, temperature is at 40 degrees and everything is okay after I deleted and reinstalled the app. I think the first installation has some problems. Thanks your reply.



I have the same problem, when I am working in PhoStorm my macbook is heating up and keeps temperature around 77-80 C
But when I switch to vs code with the same projects, temperature goes down to about 55 C.
I've disabled all unused plugins but it's still heating  up. MacBook Pro (16-inch, 2019) with 2,6 GHz 6-Core Intel Core i7 and 16Gb RAM.
May be somebody knows how to solve this?


Hi there, just reinstall, it works in my case. 


So it seems this helped

Not 100 percents, but CPU temperature is much lower during the day


The system is heating up very much with in mins after launching IntelliJ IDEA or WebStorm. Any possible solution?



MacBook Pro M1 16GB 

IntelliJ Details:

  • Version: 2022.2.3

Did you try to perform the workarounds mentioned above? Also, we recommend you try to disable third-party plugins and check the performance after that.

If you experience high CPU usage after launching IntelliJIDEA and WebStorm, please, submit a request using the contact form and attach a CPU snapshot; to obtain it, perform the following steps:

  • click  Help | Diagnostic Tools | Start CPU Usage Profiling after IDE start;
  • ensure that CPU usage is high and wait for several minutes;
  • click on the  Help | Diagnostic | Stop CPU Usage Profiling to save the snapshot file.

Hi, I have the same problem with my Mac mini and Ventura. What can I do to stop this overheating. I am using the latest version of IntelliJ with Ventura. Mac mini i7, 3.2GHz, 32GB Ram. This problem only appears when using IntelliJ.


Just upgraded to latest version Build #IU-231.8770.65, built on April 27, 2023 .. and fan start to run like crazy, it wasn't happening before .. 2022.3 worked fine (Mac Book Pro 19, i7)


I rolled back to 2022.3 .. I will use it for few days then will update again to IU-231.8770.65 ... then will share my observations and CPU snapshot..



I'm having the same problem on IntelliJ IDEA 2023.1.1 (Ultimate Edition) Build #IU-231.8770.65, built on April 27, 2023 Runtime version: 17.0.6+10-b829.9 aarch64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.

On a MacBook Pro with M2 Max chip, macOS 13.3.1 (a) (22E772610a)

Just clicking around on different lines in a javascript file has the CPU above 40%. I only noticed because the IDE started freezing frequently (every 10-20 seconds). This is rendering my IDE almost unusable. My mac doesn't seem to have the "Automatic graphics switching" option Jk280679 suggested. 


Will do. Oddly, this seems to only happen on one of my external monitors (but not the other). I have had other external monitor related issues (potentially related to the fact that my monitors are rotated 90 degrees) on this machine. However none of my other applications are having problems on this monitor like intellij is. 


BT- your comment helped me to understand the problem , its only when editing on main display , it happens to me even with sublime text not just intelliJ.
So if i switch between the monitors (2 external) - the extended monitor does not suffer from this.


Could you please check with 2023.1.2? 


@Yaroslav bed - if you asked me , then i'm working with 2023.1.2 (Ultimate Edition)



Thanks. I you case it looks like some general OS issue if other applications are affected as well.


Same here with PhpStorm 2023.1.2 and Big Sur 


Irene Iaccio 

CPU is used while the projects are indexed and when you edit the code (to run inspections, highlighting, etc.). If CPU usage is high while the IDE is idle, a CPU snapshot can help understand what's going on and possibly fix it.

Have you tried workarounds from this thread? Specifically, reinstalling the IDE and enabling this system setting.

See if it helps to update the IDE to the latest version 2023.2.2.

Other solutions to try:

  • Increase the heap size in Help | Change Memory Settings. If it is too low, Garbage Collection process runs too often, using up the CPU and slowing down the IDE. You can increase it up to 85% of overall available memory.
  • Temporarily disable all downloaded plugins and restart the IDE: Preferences | Plugins | ⚙ | Disable all downloaded plugins
  • Switch the runtime JDK to default JetBrains Runtime in case something else is selected.

If the problem persists:

  1. Capture a CPU usage snapshot. To keep the readings clean and on point, start the profiling only when performance actually drops, and stop it right after you are done testing.
  2. Take a screenshot of the Help | Diagnostic tools | Activity Monitor window while experiencing high CPU usage
  3. Collect the logs: Help | Collect Logs and Diagnostics Data (entire archive)
  4. Upload everything over for analysis to and share the generated upload id here.

Most often this happens because of plugins. I use IDEA for 20 years now, and all my performance issues were plugin related.

Thanks to the instructions from Olga Mulina I was able to identify that in this case of high CPIU for me, it was a bug in Svelte plugin that would try to auto-complete the code in unrelated project, consuming most of ForkJoinPool threads. Disabling it solved the issue in IDEA Ultimate 2024.1. 


Thank you for the information.
Do you have a link to the mentioned issue report? Mentioning it here could help other users with the same problem.