Rust wasm-pack is not installed

I have installed wasm-pack via their installer and now want to build my rust code using the Rust plugin into a webassembly binary.

As you can see, I have version 0.10.2 installed. Running

wasm-pack build --target web

from the command line in the project directory compiles my project fine.
However, "running" the project in IntelliJ just shows me this message

which is kind of weird as I clearly have wasm-pack (with a newer version) installed.
I tried invalidating caches and restarting the IDE as well as my computer but it still does not work.
Any idea what to do?

Edit: Even running the above command in the IntelliJ Terminal compiles fine, maybe the plugin doesn't check if wasm-pack is installed? Or maybe it only checks if it is installed via cargo?

Edit 2: I now ended up just using a "Shell Script" configuration with "Script text" and the above command. This runs and compiles my code just fine, although it does not solve the initial problem.

评论操作 固定链接

I have the same issue since I reinstalled Clion and wasm-pack. I think the issue was not present approx. a year ago.

0
评论操作 固定链接

Sadly the problem persists. What's worse, it's still impossible to install wasm-pack on windows using cargo, so the "install" command fails.

0

请先登录再写评论。