Clion won't load a cmake project

已完成

after two weeks of trying everything I can, I'm pretty hopeless.
while I try to generate a new project through cmake, clion is stuck on 'loading symbols', which gets the entire software stuck too, 
and raising the memory usage to almost 100%.
I've tried everything, such as reinstalling clion, cmake and ubuntu, but nothing seems to help, saw other posts, no solution. 
( I've also Invalidate Caches/ Restart a bunch of times)


as I've said, hopeless here. would be so thankful for your help!

评论操作 固定链接

Hello!

Are you trying to create a new project in CLion or are you trying to open an existing project?

Did you remove the configuration directory and the system directory when tried reinstalling CLion?

2
评论操作 固定链接

Hey Anna, thanks for your answer!

1. It happens for both of the options
(if to be precise, I mainly work with projects from VCs, through my university's GitHub links).
2. I'm pretty sure I did, when the uninstalling ask me whether to remove something I clicked yes, even though I'm not 100% sure.

either way, after waiting a couple of hours (!) the 'loading symbols' finished, but it happens every time I open the software, and memory is still on 96% (8RAM) just cause of clion. 

thanks again
Dolev

0
评论操作 固定链接

Please do Help | Collect Logs and Diagnostic Data and send the resulted archive to clion-support at jetbrains.com. Note that logs might contain private user's information (like file paths and names).

0

请先登录再写评论。