Attach Intellij profiler not working

已回答

I'm trying to generate jfr for a java 8 application running on jboss 7.2. For this when we select "Attach Intellij profiler" it is not running. It is failing with below error

Exception in thread "Attach Listener" 12:50:45,338 ERROR [stderr] (Attach Listener) java.lang.NoClassDefFoundError: jdk/jfr/FlightRecorderListener
[ERROR] Failed to initialize JfrSync class

We are able to generate jfr from jcmd command for the same application. 

Any pointers on how to fix this issue. 

 

 

评论操作 固定链接

Please attach the idea.log file (Help | Show Log in...) after restarting the IDE and reproducing the problem.

You can upload it securely to https://uploads.jetbrains.com/ and provide the upload id here.

0
评论操作 固定链接

Hello

I have the same problem. I uploaded part of the log file (running an integration test with profiler and then restarting the Ide), see upload id: 2022_08_02_dgVdtmgYWpLEHaHkxZqjT5 (file: intellij-profiller-not-working.log)

0
评论操作 固定链接

Hi Gabi,

What brand & version of the JDK is used in your project? Is it the same that you ran jcmd on?

There a low memory signal event in the log right in the midst of the profiling session. Have you tried increasing the -Xmx value for the IDE process? Help | Change Memory Settings

0
评论操作 固定链接

I'm using Oracle jdk1.8.0 331 for the project. I increased the memory setting from the menu to 2G but I have the same behavior.

See upload id: 2022_08_03_239Wsu9MKWwZwB4tVRcq2o (file: intellij-profiller-not-working2.log)

0
评论操作 固定链接

Thanks Gabi.

I created https://youtrack.jetbrains.com/issue/IDEA-299221 for this. Developers will take a look and advise.

Feel free to follow the ticket for updates. See this article if you are not familiar with YouTrack.

0

请先登录再写评论。