I cannot update the maven remote repositories



Please provide the idea.log file (Help | Show Log in...) after restarting the IDE and reproducing the problem.

You can upload it securely to https://uploads.jetbrains.com/ and provide the upload id.


This is the id of the log file: Upload id: 2022_06_08_AVFepEz5369WW95SN5E9Er (file: idea.log)


The error is:

java.lang.IllegalArgumentException: Unsupported protocolTLSw1
  at java.base/sun.security.ssl.ProtocolVersion.namesOf(ProtocolVersion.java:292)
    at java.base/sun.security.ssl.SSLSocketImpl.setEnabledProtocols(SSLSocketImpl.java:362)
    at org.apache.maven.wagon.providers.http.httpclient.conn.ssl.SSLConnectionSocketFactory.createLayeredSocket(SSLConnectionSocketFactory.java:399)
    at org.apache.maven.wagon.providers.http.httpclient.conn.ssl.SSLConnectionSocketFactory.connectSocket(SSLConnectionSocketFactory.java:384)

If you are using a proxy server, make sure that proper TLS protocol versions are used.


Im not using any proxy or VPN, and I reinstalled the entire program.

It only happens in Intellij, I tried to install the dependencies with another IDE (STS) and it works correctly


Do you run the IDE in WSL?

What version of Maven is used in the IDE? File | Settings | Build, Execution, Deployment | Build Tools | Maven

Does it help if you clear the contents of C:\Users\user.name\AppData\Local\JetBrains\IntelliJIdea2022.1\Maven\Indices and try to update the repository again?


I never configured the IDE in WSL

The Maven version is the 3.8.1

I deleted the folder but the problem continues


TLSw1 name that we see in the error is a very strange protocol version. I have never seen such a name before and there is also no such a protocols with such a name in JDK sources. I can suspect this value is specified somewhere in your environment. Normally the Java client application can use these properties to specify the TLS version:


Try specifying TLSv1.3 or TLSv1.2 versions for TLS protocol in IDE platform .vmoptions (use Help | Edit Custom VM Options action to open custom vmoptions file) and IDE Maven Imported VM options (Settings (Preferences on macOS) | Build, Execution, Deployment | Build Tools | Maven | Importing | VM options for importer field) and restart IDE.

Also check your environment - where this property might be possibly specified.

Try starting IDE with default settings (File | Manage Settings | Restore Default Settings... action).

Also make sure the same Maven version and same JDK are used in terminal where it works as in the IntelliJ IDEA:

Settings (Preferences on macOS) | Build, Execution, Deployment | Build Tools | Maven | Maven home path:

Settings (Preferences on macOS) | Build, Execution, Deployment | Build Tools | Maven | Importing | JDK for importer:

To specify it via the VM options you can like following:


Hi, Andrey. I tried to do what you wrote in the comment. It didn't work. Still the same.


The JVM options must be prepended with -D, please check the previous message for an example. Also do try using different protocols.


Oh I'm sorry. Now it works! Thank you very much. you just made my week


Great! Thank you for the information.


Maven remote repository indexing is not working in Intellij 2024. The [Update] button is active, but clicking it does nothing



Does update start if you close settings dialog after pressing “Update” button?


Yes, for me the Update button is active (styled like the Cancel button in Settings), but it does not respond to clicks. I've restarted intelliJ and my computer several times. I've waited an hour. Additionally, the “Updated” column is blank, not sure if that is unusual. 


Darockstop Make sure you have a repository selected when you are clicking “Update” button.

In the current version of IDEA “Update” button queues the reindex, but the process starts once you close the “Settings” window.

If it does not work as intended in your environment you can close all instances of IDEA and remove “Maven” folder from IDEA's System Directory to force IDEA to rebuild indices from scratch.