Help with the Datagrip Bigquery connection

已回答

Hello everyone,

I have a question regarding the authentication via the google user account when connecting datagrip with google Bigquery. Once I set up the Data source and added the authentication via a google user account (as shown in the jetbrains documentation), I have to add the authentication code every time doing an operation in data grip. Can this state be avoided so that I have to enter the access token just on the first time of the new connection (initially)?

评论操作 固定链接

Hello,

Please open up data source properties, go to Options tab and enable Single session mode.

Does it help?

0
评论操作 固定链接

Hey Daniil,

yes, I already did but it doesn't work. I still have to reenter the access token.

kind regards

0
评论操作 固定链接

what exactly do you want to know? And can you tell me where I can find the specific Bigquery connection in my data grip?

 

0
评论操作 固定链接

A screenshot of your Services tool window (View | Tool Windows | Services) would be helpful.

You can find details about your connection by clicking on the data source name and selecting Data Source Properties button.

0
评论操作 固定链接

alright, this is the screenshot from my service window tool

 

0
评论操作 固定链接

Could you please share a screenshot with BigQuery execution and the expanded tree of Google BigQuery_test? I see an example of PostgreSQL on your screenshot, which is not so relevant in our case.

0

请先登录再写评论。