Rubymine For M1 Mac Mini Guide?

Is there a definitive guide for getting Rubymine working correctly on Apple Silicon.
So far it has been a real slog. I am using chruby as supposedly that is the new best thing for managing ruby versions ( I am restarting after a long break ) but I have tried rbenv too which is also problematic.

Issues include
Not detecting a Ruby SDK

debase gem being iffy

Debugger not working

I have had various bits working at various times but have spent way too much time ploughing through possible solutions. There always seems to be some bit that is broken.

Is there a good resource for this specific issue. I know I'm not the only one to have problems.

评论操作 固定链接

Hello! We’re sorry to hear that you've experienced a problem with RubyMine. Could you please share a bit more information about issues you faced? What RubyMine version you’re using?

0
评论操作 固定链接

Thanks for your response. I am using the latest version ( I had a fallback version originally but that had problems so downloaded the latest to see if it was a not supported type problem ).

I wasn't specific because I am very confused with all the different things I have tried and have ended up not quite sure what are the basic problems.
I am using Rubymine and use chruby for version management ( used to use RVM but read this was a simpler solution these days ).

1. Initial problem was with debase not compiling for the correct architecture. A removal of all gems, a clean --force and installing the --pre version of debase seemed to fix this. Seems really hacky.
2. A common problem I get is persistent "No SDK specified" errors. I did get it working at one point but not sure how. It doesn't seem to autodetect my chruby install. This is the problem I have at the moment.

3. I did on one occasion somehow manage to get it to recognise the chruby specified SDK. I then tried to start debug and it prompted me to install the gems. It did this but the gems crash. I have had different error message but have never managed to get it to work.

This is why I was wondering about an M1 guide so that I know I am following the correct setup and know which gems to use and any bits that need to be hacked. At the moment I am just stabbing around in the dark. Never used to have these problems on Intel, debug worked perfectly.

0
评论操作 固定链接

Hello again! Thanks for the detailed feedback. There is indeed a problem with chruby auto-detect, I filled the issue https://youtrack.jetbrains.com/issue/RUBY-30023/RM-doesnt-detect-chruby
Also, there is another issue when you try to add chruby in the "New Project" screen. RubyMine has different actions for adding pure ruby ​​(eg system ruby) and ruby ​​managed by version manager (chruby, rvm). Due to usability issues, an action for pure ruby ​​is called in RM's "New Project". I also filled issue for this
https://youtrack.jetbrains.com/issue/RUBY-30024/Impossible-to-add-manually-add-Ruby-Version-Managers-at-New-Project-dialogue

Sorry for the above inconvenience  and let me propose workaround for you on how to add your chruby to RM:

  1. Open RubyMine
  2. On Welcome Screen invoke ⌘ + , (shortcut for Preferences)
  3. Go to `Languages & Frameworks | Ruby SDK and Gems`
  4. Select `+` -> `Version Manager...`
  5. In opened window select path to `chuby.sh` (if `chruby` installed via `brew`, you can find path to `chruby.sh` via `brew info chruby`)

As a result, `chruby` will be added to RubyMine.
Also please ensure, that you use RubyMine for Apple Silicon (https://www.jetbrains.com/ruby/download/#section=mac)

0
评论操作 固定链接

Thanks for your reply. I will try out those instructions. I am using the Apple Silicon version.

I am using the Jumpstart Rails template so that in itself has a lot of stuff that I am not yet familiar with.

0

请先登录再写评论。