Disabling RubyMine Debugger Watches Autocompletion

Hi,

Currently on 2021.2.4. Whenever I add a new watch in the debugger, there's an autocomplete feature that gives me options for whatever watch name I'm typing. When I'm done typing I press enter (to add my watch) and the debugger autocomplete takes my value and changes it to whatever is first on the autocomplete list, which most often than not is not what I intended. The only way to prevent this is to press ESC key before enter, which sometimes means the "new watch" entry is discarded and I have to type it again.

e.g. I'm typing "variab", autocomplete will list "some_variable"; I continue to fully type "variable", then I press enter and my "variable" entry changes to "some_variable" due to autocomplete. 

I've not found a way to just disable the watcher/debugger autocomplete.

Any ideas? Thanks.

mc

评论操作 固定链接

Hello! Unfortunately disable Code Completion only for Watches at the moment
You can disable all Code Completion at `Preferences | Editor | General | Code Completion` -> `Show suggestions as you type`

0

请先登录再写评论。